4 Replies Latest reply on Jul 1, 2014 11:43 PM by Fred(CH)

    Cannot remove formatting when entering text into fields

    BillDawes

      Summary

      Cannot remove formatting when entering text into fields

      Product

      FileMaker Pro

      Version

      13.0v3

      Operating system version

      windows 8.1

      Description of the issue

      Since upgrading from FMP 10 to 13 it now imports formatting to fields whereas previously it just pasted text.

      I have to remove the formatting manually which is painful.

      I have tried following these steps but it changes the field name

      Method 1: Prevent text from being formatted during data entry.

      A field can be defined to make sure data is entered in a specific format, or within a certain range. To save time and ensure accuracy, you can set FileMaker Pro to automatically enter unformatted data in a text, number, date, time, and container fields. For example, field.

      To set options for automatic data entry:

      With the database open, choose File menu > Define > Database.
      In the Define Database dialog box, click the Fields tab.
      If your database contains more than one table, select the appropriate table from the Table list.
      Select your text field from the list of existing fields, or define a new one, for example fieldA.
      Click Options (or double-click the field name).
      In the Options for Field dialog box, click the Auto-Enter tab and select the Calculated Value (or click Specify), then enter the following calculation.

      TextFormatRemove(fieldA)

      To make an auto-enter calculation self-modifying, leave the Do not replace existing value for field (if any) option unchecked.

        • 1. Re: Cannot remove formatting when entering text into fields
          philmodjunk

               This behavior change that is not new to Filemaker 13 (I forget if it was introduced in 11 or 12) brought windows systems into "synch" with what happens when pasting from the clipboard in Mac systems. I use TextFormatRemove ( Self ) in my systems as I can copy/paste this from text field to text field.

          • 2. Re: Cannot remove formatting when entering text into fields
            BillDawes

                 But all of the fields have now defaulted to Title case, and I need to manually change them back to plain text so consecutive capitals in Titles or Adresses return, how do i reprogram it so that all fields return to their original state?

            • 3. Re: Cannot remove formatting when entering text into fields
              Fred(CH)

                   Hello,

                   For your existing data there are many ways.

                   1 ) I you have few concerned fields you can use Phil's formula on a Replace field content (but self must be replaced by <field name>) where the found set is "all record" and repeat it for each field.

                   2 ) If there are a lot of fields, a radical way is text export+import.  You can export all records and all concerned fields, one shot, for instance to a XLSX file* and then reimport with them with option Update existing records in found set, checking carefully that fields of source and target are matching together (you can use "matching names" Arrange by mechanism).

                   WARNING : Be sure to have one (or more) up-to-date backups copy just before to proceed.

                   * Basically i prefer using Tab-Separated Text, but XLSX offer the control of fields name.

                   Good luck, Fred

              • 4. Re: Cannot remove formatting when entering text into fields
                Fred(CH)

                PS : if you choose XLSX import, be sure to check…

                     [ X ] Don't import first record (contains field names)

                     …on Import Field Mapping dialog.