6 Replies Latest reply on Jan 4, 2012 10:44 PM by MikeWallis

    Cant Print FileMaker Pro 11

    trodifer

      Summary

      Cant Print FileMaker Pro 11

      Product

      FileMaker Pro

      Version

      V11

      Operating system version

      Windows 7

      Description of the issue

      I been using FileMaker Pro for years and understand the program fairly well however I have a new PC with Windows 7 and a new Brothers Printer that can't print anything from FileMaker. However I can print from all other programs on this PC, like Microsoft Word, Note Pad, Adobe PDF, and off the internet. I updated the printer drivers and installed Windows's 7 service patch but I still cannot print from FileMaker Pro 11. Anyone have any ideals on what to do next.
      When I try to print, the print window does comes up and I then click on the print button but nothing happens, no icon comes up in the task bar and nothing prints out.

      Steps to reproduce the problem

      Click on the print button
      No icon comes up in the task bar and nothing prints out.

        • 1. Re: Cant Print FileMaker Pro 11
          philmodjunk

          I realize that you may not be able to try this, but if you can...

          Have you tried printing to a different printer? This can help determine if the problem is specific to the Brother Printer you have.

          Have you tried printing using a completely different FileMaker file? This can rule out issue with your file.

          • 2. Re: Cant Print FileMaker Pro 11
            AGJVerein

            Same Problem here ! Lexmark Parinter 782 and several other printer.

            FM 11v3 stops working under win 7 x64, nothing happens. Filemaker crashed.

            On Other PC the database prints out fine.

            • 3. Re: Cant Print FileMaker Pro 11
              philmodjunk

              On Other PC the database prints out fine.

              Do these other PC's use Windows 7?

              If so, then there is some issue with that one computer. If they are windows XP, Vista, or Mac systems, then it could be an incompatibility with the windows 7 printer driver and FileMaker.

              • 4. Re: Cant Print FileMaker Pro 11
                AGJVerein

                 

                Sorry but the issue ist still there.

                1.

                I can NOT print from Windows 7 Ultimate x64. I have several printers. None works with Filemaker.

                 

                2.

                Windows 7 Professional x32 in virtual machine can print from Filemaker 11v3 Pro Adv.
                No Problem there.

                 

                Do you have any idea ?

                • 5. Re: Cant Print FileMaker Pro 11
                  philmodjunk

                  As a test, can you run the windows 7 ultimate X64 in 32 bit compatibility mode and see if that makes any difference?

                  I have not had any problems printing from my Windows 7 Home Premium 64 bit lap top so see no reason why you cannot print at all from that machine.

                  • 6. Re: Cant Print FileMaker Pro 11
                    MikeWallis

                     Hi All,

                    We have run into this problem also. Here is the setup and one way I have been able to get it to work.

                    Workstion is running Win 7 64 bit enterprise, is joined to an Active Directory domain.

                    Printing is via a Windows 2008R2 64bit Print Server.

                    Running FileMaker Pro V11 (not sure of the minor version as I am not in front of the machine right now)

                    When prinitng to a netork printer we get an error such as the "Filemaker is unable to continue printing. (error)" or "Cannot print as the printer has no port". This is not the exact message, but pretty close.

                    After a bit of research I noticied that earlier versions of FM had problems printing to printer names longer than about 30 characters. On machines using Windows Print servers, you will probably find that the servername is pre-pended to the printer name which often causes the name to be longer than 30 characters. An example of this is (\\printers.subdomain.domain.edu.au\LabName-PrinterName)

                    I decided to try printing directly to the printer (i.e. as a tcpip printer) rather than via the print server and hence could enter a name such as 'Office' which is much shorter than that used to connect via the print server.

                    Printing to this printer seems to work OK.

                    I dont know if it was the length of the printer server/queue name or the fact it is going through a MS Print Server generally, but the direct printing method has worked reliably for at least 2 days now. Interestingly, if you try and print to the Windows Print Server the error re-appears and nothing will get rid of it (even changing back to the working printer) until FM is re-started.

                    By the way all applications excpet FM can print using the Print Server without issue.

                    Hope this helps someone and if anyone has more info, I would love to know.

                    Regards

                    The LANMAN