1 Reply Latest reply on Feb 24, 2011 8:58 AM by TSGal

    Charts can't handle international numbers (comma-separated decimals)

    wirsberg

      Summary

      Charts can't handle international numbers (comma-separated decimals)

      Product

      FileMaker Pro

      Version

      11v2

      Operating system version

      Mac OSX 10.6.6

      Description of the issue

      chart object doesn't handle International decimal numbers, separated by comma ",", instead charts ignores the comma and reads a decimal i.e. "2,1" as "21".

      Steps to reproduce the problem

      - open a FM file with 
         > File Option > Text > "Ask whenever settings are different"
      - look at a chart based on decimal numbers.
      - In Mac OSX system's settings, go to "international > formats > numbers" and set decimal separator to comma ",". You can leave the window open.
      - switch back to Filemaker's open file showing a chart. Have the file use "systems settings" if asked. have the window's contents get refreshed. See decimal numbers automagically and transform to use "," as separator as expected. (the data formatting settings of number fields should be "general"). Look at the chart and see how the chart's bars jump wildly as the chart now ignores the "," decimal separator in the numbers based on!
      - go back to MacOS and switch systems format settings back.

      Expected result

      2.1

      Actual result

      21

      Exact text of any error message(s) that appear

      none

      Configuration information

      File options > Text > "use current system's settings"

      operating system's number format: "2.345.678,9" (comma as decimal separator)

      Workaround

      none

      FM11-Charts-error.png

        • 1. Re: Charts can't handle international numbers (comma-separated decimals)
          TSGal

          wirsberg:

          Thank you for your post, and I apologize for the late reply.

          I am unable to replicate the problem using FileMaker Pro 11.0v3 under Mac OS X 10.6.6.  Here are the steps I took.

          1. I created a file with five number fields: Field1, Field2, Field3, Field4, Field5

          2. I entered the same data as your example into the fields.  That is, 4, 2.4, 2, 1.6 and 0.9

          3. I created a bar chart (flat) and specified the five fields for the Y-axis.

          4. In Browse Mode, the five values appear properly in the chart.

          5. I quit FileMaker Pro, entered System Preferences -> Language & Text -> Formats -> (Numbers) Customize...   and changed the Number Separators for Decimal (period to comma) and Thousands (comma to period).

          6. I launched FileMaker Pro, opened the database file, and the chart still displays properly.

          I am aware that a month has passed, so if you have found a solution, please post here so others can benefit.  If you are still encountering the problem, please let me know what I'm doing differently than you, and I'll try to replicate the problem here.

          TSGal
          FileMaker, Inc.