1 Reply Latest reply on Oct 22, 2014 7:20 AM by TSGal

    Check Box in Vibrant Theme displays text outside of object

    JohnDuncan

      Summary

      Check Box in Vibrant Theme displays text outside of object

      Product

      FileMaker Pro

      Version

      13.0v3

      Operating system version

      Mac OS X 10.9.5

      Description of the issue

      A Checkbox object is linked to a value list with the single value "1" (without the quotes).  The display of that object on the layout with theme "Vibrant" is resized so that the width of the object is only 1 px wider than the checkbox itself.  In layout mode it looks fine but when viewed in browse mode the "1" appears next to the checkbox even though it is outside of the bounds of the object.

      Steps to reproduce the problem

      Create a field, create a value list with the value 1, put the field on a form-view layout in the Vibrant theme.  Resize the bounding box of the check box so that the width is just wider than the checkbox itself.  View the layout in "Browse" mode and the 1 will show in an area outside the bounding box of the object.  The problem only occurs at zoom level 100% or 75% not at enlargements.

      Expected result

      the 1 should not be visible

      Actual result

      the 1 is visible

      Exact text of any error message(s) that appear

      N/A

      Workaround

      A partial workaround is to change the color of the text box to match the background but in our case it is displayed on a portal with alternating background colors so there is no single color choice that will work.  Another workaround which will work for this example but not for longer text strings is to decrease the left margin and increase the right margin to force the text to slide "behind" the checkbox.

        • 1. Re: Check Box in Vibrant Theme displays text outside of object
          TSGal

          John Duncan:

          Thank you for your post.

          I am unable to replicate the issue.  This is what I have done:

          1. Using FileMaker Pro 13.0v3 under Mac OS X 10.9.5, I create a database file Test.fmp12.

          2. I created one Text field named Checkbox.

          3. In Layout mode, I changed the Theme from Enlightened to Vibrant.

          4. Still in Layout mode, I selected the Checkbox field and formatted it as a Checkbox set, creating and applying a value list that contains one custom value "1" (without quotes).

          5. I sized the field so the "1" does not appear.  The right side of the field is two or three pixels larger than the checkbox.

          6. In Browse Mode, the "1" does not appear.  I switched between all zoom levels from 25% up to 400%, and the "1" never appeared.

          Let me know what I'm doing differently than you so I can try to replicate the issue.

          Do you have any special graphic cards?  What model Mac is being used?  If another Mac is available, are you able to replicate on the other Mac?

          Any other information you can provide to help me replicate the issue may be helpful.

          TSGal
          FileMaker, Inc..