1 2 3 Previous Next 233 Replies Latest reply on May 12, 2016 4:12 AM by bigwal

    Clipboard not working

    mcconns

      Summary

      Clipboard not working

      Product

      FileMaker Pro

      Version

      11 and previous versions

      Operating system version

      Windows 7

      Description of the issue

      Hi,

      We have a couple of users who are using Filemaker (one on version 8 the other on version 11). Both are running it on PCs with Windows 7. They have reported that the clipboard functionality intermittently stops working. They copy something and paste it but nothing is pasted. There seems to be no pattern to this.

      I had a look on your forums and found a couple of posts where other people have experienced the same thing and indeed the problem seems to go back through several Filemaker versions. Is this a know issue that you are working on or do you know of a fix to sort this?

      Steps to reproduce the problem

      No way to reproduce as there does not appear to be a pattern.

      Expected result

      Clipboard contents should be pasted into field

      Actual result

      Nothing is pasted

      Exact text of any error message(s) that appear

      No error reported

        • 1. Re: Clipboard not working
          TSGal

          mcconns:

          Thank you for your post.

          When you pull down the Edit menu, is Paste available or grayed out?  If available, select it.  Does the information paste?

          What type of field are you pasting into?  Is there any special formatting for the field?

          Since this is happening "itermittently", can you find out what steps the others were taking just prior to this not working?  How long was FileMaker Pro open prior to this occurring?  What other applications are currently running?  Any other information you can provide may be helpful.

          TSGal
          FileMaker, Inc.

          • 2. Re: Clipboard not working
            philmodjunk

            Are there any script steps that use copy? If a script using copy is run, it will replace the users copied data with that copied by the script.

            • 3. Re: Clipboard not working
              mcconns

              Hi,

              Thanks for the replies, in answer to both of you.

              Re the menu – I’ve tried all 3 copy/paste methods – from the menu, Ctrl-C/V and right click – they all give the option to copy, but don’t always give the option to paste, which is sometimes greyed out. It seems to be the copy function that doesn’t work sometimes. I’ve tried all possible permutations of these methods with each other, and can see no logic to why it works and then doesn’t.

               The problem is sometimes with pasting into a Word doc and sometimes into an Excel sheet, sometimes into formatted cells, but nothing complex – the information pasted should always be compatible with the cell formatting.

               Usually Filemaker would have been open for a while, because it tends to be open all day on my machine. Other programmes running at the same time would usually be Excel, Word, Quicktime, Outlook.

              No scripts are running on the database at the time.

               

              • 4. Re: Clipboard not working
                TSGal

                mcconns:

                Thank you for the additional information.

                Since the copy function doesn't work after FileMaker Pro has been open "for a while", if you quit FileMaker Pro and relaunch, does the Copy command then start working?

                Having Excel, Word, Quicktime and Outlook open should not cause any issues with FileMaker Pro.

                TSGal
                FileMaker, Inc.

                • 5. Re: Clipboard not working
                  philmodjunk

                  No scripts are running on the database at the time.

                  That's not quite what I am getting at. The script may have been run after they copy, but before they attempt to paste. The script isn't running at the current moment, but it may have replaced the data the user copied with data copied by the script and this could be data of a form that won't paste successfully into the other application--which might disable the paste option.

                  • 6. Re: Clipboard not working
                    mcconns

                    Hi,

                    I have managed to recreate this problem in a new database, so I think I can rule out scripts, field formats other applications.

                     

                    I opened a new instance of Filemaker and created a new local database with one table and one text field. I entered data in the field and tried to copy this. If I then try to paste into notepad the paste option is greyed out. Similarly if I try to paste into Filemaker it is also greyed out.

                    I then closed Filemaker and opened it again. Tried copy and paste, again it failed.

                    Closed and opened Filemaker again, this time copy worked.

                    Repated open and close of Filemaker and attempts at copying produce random results where the copy either works or doesn't.

                    I personally use Filemaker 9 connecting to a server 9 instance. The other users that are experiencing this are using v8 and v11 clients connecting to a v8 server.

                    As stated in my original post there are other forum posts with similar issues and no suggested fix. Perhaps this has been fixed in recent releases.

                     

                     

                     

                    • 7. Re: Clipboard not working
                      philmodjunk

                      As stated in my original post there are other forum posts with similar issues and no suggested fix.

                      Can you post links to any of these? I've been monitoring this forum for quite a while now and don't recall any such posts here in this forum, at least. That could be a faulty memory on my part and if so, I'd appreciate the chance to refresh my memory on this one.

                      Been using copy and paste on windows xp, windows 7 with versions 10, 11 and 12 and haven't noticed any such issues.

                      • 8. Re: Clipboard not working
                        mcconns

                        Hi,

                        Here is the link to the post, I thought there was a 2nd one but it was just a link within this thread back to itself.

                          http://forums.filemaker.com/posts/647742b7d1?start=11&stop=20 

                         

                        Thanks

                        • 9. Re: Clipboard not working
                          CraigStevenson

                           We have also seen extensive clipboard issues with FileMaker Pro going back as far as version 9.  (We currently use version 11.)  When we first started with FileMaker (v9), we did not know for sure what was causing the clipboard issues.  We spent MANY hours of time troubleshooting everything clipboard related, without really ever focusing on FileMaker.  Eventually, we isolated the Windows clipboard problem directly to FileMaker.  We run mostly "virtual systems", in which we use Microsoft's Remote Desktop (RDP) to access each system.  Recently, my own system was a victim of these problems.  Although FileMaker was installed, it normally was not used.  Two days ago, I decided to keep FileMaker running while I was working on modifications to a database.  All of a sudden, my clipboard doesn't work right anymore.  I copied some text, switched to another system, and pasted something into another program.  Unfortunately, what I pasted wasn't what I had copied.  (It was data from a PREVIOUS copy.)  I tried this several times, with the same result.  I closed down FileMaker, disconnected from the RDP session, reconnected, and tried the copy again, and it worked perfectly.  There is (and has been for a long time), some sort of issue with FileMaker and the Windows clipboard.  It appears to be aggravated significantly by a remote (RDP) session.  Another person here, has been fighting this issue for YEARS!  At times, she will have to copy something MANY times to get the data into the clipboard.  If she cuts data, to try and paste it into another field, when she goes to the destination field and issues the paste command, the data is GONE!  The problem seems worse when copying/cutting and pasting between two different RDP sessions, but she has seen the problem when copying/cutting and pasting on the same RDP session as well.

                           

                          • 10. Re: Clipboard not working
                            CraigStevenson

                            I would also like to add that this particular problem (in my opinion) will never be fixed until information from this thread is given directly to the FileMaker programmers. They need to look at the way they are handling the Windows clipboard, especially with regard to how they are handing control to the NEXT clipboard handler in the chain. Somehow, the clipboard chain is getting corrupted. This problem goes well beyond the capabilities of front line technical support people. (MSCONFIG, redownloading the program, reinstallation, etc. isn't going to solve this issue.) It is also something that most users will not see unless they are very heavy FileMaker users, which makes it next to impossible to provide a reproducible test case. There is no doubt that RDP exacerbates the problem, so if a technical support person wants to try and reproduce this, an RDP session would be good place to start.

                            I'm also trying to avoid the same headache that occurred in this thread: http://forums.filemaker.com/posts/52d7854c45 To sum it up, I submitted a detailed error report containing a VERY SPECIFIC error message, and was told to do a bunch of things that really had nothing to do with troubleshooting the original problem. I don't think that the actual error message was ever reviewed thoroughly. I finally ended up troubleshooting it and finding the solution myself. I understand that many issues are caused by user error, but this isn't one of them.

                            As far as FileMaker clipboard issues go, I have literally spent YEARS troubleshooting this, and I can say with some certainty that FileMaker is the culprit, and that it is caused by a FUNDAMENTAL problem with FileMaker's handling of the Windows clipboard.. Please take these reports of clipboard issues seriously. I am willing to beta test in our environment IF FileMaker is serious about finding a solution. (That means moving well beyond Level 1 technical support, and working with the people who write the code.) We can reproduce this problem 100% of the time, usually within a matter of hours. I don't think too many other users can make that claim.

                             

                            • 11. Re: Clipboard not working
                              TSGal

                              Craig Stevenson:

                              Thank you for your post.  The original poster is talking about Windows 7, and your issue has to do with remote desktop and Terminal Services that you posted at:

                              http://forums.filemaker.com/posts/c67c5t52c81

                              Please see the above thread for more information and responses to your inquiries there.

                              TSGal
                              FileMaker, Inc. 

                              • 12. Re: Clipboard not working
                                CraigStevenson

                                TSGal,

                                My apologies.  I wasn't aware of the other threads until after I had posted here.  I have re-posted my information on the other thread.  I do think that the clipboard issues discussed here COULD be related to the clipboard issues reported under terminal services.  (It at least points to a fundamental clipboard issue of some sort with FileMaker, since it affects multiple operating systems and environments.)

                                Craig

                                 

                                • 13. Re: Clipboard not working
                                  GlennSmith

                                  I've recently also had the misfortune to have copy and paste stop working with FileMaker Pro as well. A Google search led me to this thread.

                                  With no particular configuration change on my system, one day copy and paste simply stopped working on my Windows 7 64 bit machine running FileMaker Pro 11 Advanced.  The problem is intermittent, and sometimes goes away with no discernable action on my part.

                                  I checked the web for a solution, found none, uninstalled FileMaker Pro 11, then re-installed it, and the problem was gone for a while -- to return today.

                                  I've been working with FileMaker Pro since FileMaker Pro 2.1, and only ran into this problem a few weeks ago for the first time.  My company is a FileMaker Business Alliance member, and I am also a developer with experience in everything from web development to C++ development to work in assembler.

                                  Looking at the problem more closely, I see that it is the copy command that is broken, not paste.  Other programs work just fine, but "copy" in FileMaker doesn't work.  Specifically, doing a "copy" followed by "paste" either pastes no visible characters, or replaces whatever text is selected with no visible characters.

                                  After copy and paste stopped working for me today in FileMaker 11 Advanced, I opened up a copy of FileMaker Pro 6 Developer and it had the same problem.  I opened up a copy of FileMaker Pro 12 Advanced and it had the same problem.  Copy and paste work fine in other programs. This suggests that there is perhaps shared library code that is being used by all three products which is having some sort of clipboard problem. A restart doesn't help.  Copying and pasting in other programs (such as Windows Notepad) works just fine.  Copying text in Notepad and pasting it into FileMaker works.  Copying text in FileMaker pro doesn't work.

                                  I haven't installed a low level tool to see what FileMaker is putting on the clipboard (if anything) when I try to do a copy, but that might be a next step were I part of the FileMaker developer team.

                                  I would be happy to set up a screen sharing session with either FileMaker QA or one of the FileMaker dev team to show them the problem next time it occurs.  At this point, I'm glad only I'm seeing this problem and not my company's clients as this would certainly be a deal breaker in using FileMaker (a tool we love and have based much of our company's work around.)

                                  Glenn Smith


                                  --

                                  Glenn Smith
                                  President, Mighty Ant DataWorks
                                  Custom Office Automation With A 10x Advantage
                                  MightyAntDataWorks.com - (626) 817-2702 - glenn@MightyAntDataWorks.com
                                  • 14. Re: Clipboard not working
                                    CraigStevenson

                                     Glenn,

                                    I hope you have more influence with Filemaker than the rest of us.  The response from Filemaker so far has been underwhelming, to say the least.  I have an environment where this issue can be consistently reproduced within a reasonable time frame, and I have yet to be contacted by Filemaker.

                                    What low-level tool(s) are out there to monitor the clipboard?  The tools I've tried so far can't seem to figure out exactly what Filemaker is doing to the clipboard chain.  (Granted, our environment is RDP, but as you said in your post, there definitely appears to be some common code here.)

                                    Craig

                                     

                                    1 2 3 Previous Next