1 Reply Latest reply on May 8, 2012 3:16 PM by TSGal

    Color Picker 'dot' jumps

    gcKoenig

      Summary

      Color Picker 'dot' jumps

      Product

      FileMaker Pro

      Version

      12.0v1

      Operating system version

      Mac 10.6.8

      Description of the issue

      In Layout mode, on the light gray formatting bar (with the font drop down at the left), at the right hand end, there is the box called "Fill."  When you click it, a palette comes up with little square blocks of color.  At the bottom, you can choose "Other Color."  When I do that, the color picker comes up.  But the operation of it seems 'broken' in a strange way.  When I click in the middle of the color circle and drag the little white dot to a given location, then let go, the dot does not stay where I placed it, but instead jumps immediately to a location nearby.  Also, sometimes, the density slider, at the right, moves down a little bit.  If I keep trying to put the dot in various places in the color circle, wherever I want it, it always jumps to one of a number of specific locations, as if the colors are limited somehow.  And the density slider keeps going lower and lower with each click until it all turns black.  But if I choose "Fill" with the inspector, I can choose any color I want and the little dot stays in place and the slider doesn't move unless I move it.

      Steps to reproduce the problem

      I was trying to change the color of a button, in classic theme.  But the problem occurs in other themes.  I tried it on a FileMaker template database ("Inventory") and it happens there as well.  Always when choosing "Other Color" from the fill block in the formatting bar, never when from the inspector.

      Expected result

      (see above)

      Actual result

      (see above)

      Exact text of any error message(s) that appear

      no error messages appear.

      Configuration information

      I have no custom functions, custom menus, strange OS plug ins, etc. so there's nothing to interfere with FileMaker on my machine that I know of.  And the color picker works ok when I get it from the Inspector, so it can't be the OS.  Why would it work differently depending on where I invoke it from?

      Workaround

      Use the one from the inspector when I want to choose the color I want, instead of using the fill tool on the formatting bar.

      In the screenshot, I let go of the dot at the cursor arrow.  But the dot actually jumped to the location shown.

      FileMaker_Pro_AdvancedScreenSnapz057.jpg

        • 1. Re: Color Picker 'dot' jumps
          TSGal

          Glenn Koenig:

          Thank you for your post.

          I am able to replicate the problem on Mac OS X 10.7.3.  A color rectangle appears under Windows but works as expected when selecting colors under the Inspector or Formatting Bar.

          I have forwarded your post along with my findings to our Development and Testing departments for review.  I will keep you updated as information becomes available to me.

          TSGal
          FileMaker, Inc.