13 Replies Latest reply on Jun 23, 2015 6:21 AM by TSGal

    Connectivity Issues With FMP14/FMS14 From External Office

    DanielPhillips

      Summary

      Connectivity Issues With FMP14/FMS14 From External Office

      Product

      FileMaker Pro

      Version

      14

      Operating system version

      Windows 7/8

      Description of the issue

      Hi,

      We have upgraded our organization onto FileMaker 14 Pro/Server from 13. Since the upgrade, FMP14 clients from our corporate HQ are getting error messages and can't connect to the database hosted in our datacenter.

      I've done tracert from their PC to the database server and there are no issues as far as routing goes. I double checked firewall policies to make sure nothing changed out of the blue and everything is looking fine there as well. The server is using the same server settings as far as ports, IP address, database name, etc. Nothing was changed except the version of FMS running on the machine.

      The error message they are receiving is a "(Filename) is damaged and cannot be opened." although the database is working perfectly fine for clients in the datacenter where the server is physically located. It seems to be hit or miss.

      Some clients have not had an issue, but a majority of them have. What I found that fixes it for a short period (seemingly random) is completely removing the filemaker client from their machine using an uninstaller that scans the registry for leftover info, etc. and then removing the entire user profile and having it rebuild from scratch. Sometimes this will work but other times it will not and it's driving me insane.

      Is this a known issue or any reason this would occur? I am thinking of reverting the server back to v13 until this is figured out because it's causing a ton of headache.



      Thank you for your help!



      EDIT:

      It's also really weird because when adding the database to the launch center on one of the clients, it will pull the file icon of the database so it shows up in the launch center with an icon. It just won't connect, it goes to a coffee cup icon and eventually gives the damaged file error.

      EDIT 2:
      I tried recovering the file and making sure it wasn't actually damaged. File checked out just fine, no issues, still having the same bug today. Had the user just keep trying to connect and they had to wait like 10-15 times of letting it time out and then retrying before it finally did prompt them for login and let them in.

      Steps to reproduce the problem

      Happens 90% of the time when a user from an external office tries connecting.

      Expected result

      Should just show the filemaker login screen and allow them to get into the system.

      Actual result

      Goes to coffee cup / not responding for about 2 minutes until it pops up "filename.fmp12 is damaged and cannot be opened. Use the recover tool"

      Exact text of any error message(s) that appear

      is damaged and cannot be opened.

      Configuration information

      Running Windows Server 2012 with all updates installed, FileMaker 14 Server fully featured setup, FileMaker Pro 14 client for end user.

      Workaround

      Just keep trying to connect.

      One thing that seemed like it fixed it for a short period is deleting the windows user profile, using an uninstaller to remove filemaker and registry entries, reboot and reinstall then have the user login to rebuild profile. This sometimes does work but only for a little while.