5 Replies Latest reply on Jan 17, 2012 10:19 AM by TSGal

    Context menu in web viewer works incorrectly

    GlennJackman

      Summary

      Context menu in web viewer works incorrectly

      Product

      FileMaker Pro

      Version

      Advanced 10.0v3

      Operating system version

      10.5.8

      Description of the issue

      Since my last Mac software update (for me it was to itunes 10.4 and safari 5.0.6 on 27/07/2011) the 'Open link in new window' in context menu in web viewer does not open the destination page but the originating page instead.

      Steps to reproduce the problem

      Right click any link inside web viewer and select open link in new window. Safari opens same page as is showing in viewer instead of the linked page. I have tried changing default browser to Firefox but result is the same in firefox.

      Expected result

      New window should show the linked page.

      Actual result

      Shows originating page.

      Exact text of any error message(s) that appear

      None

      Configuration information

      On my other mac things are still working fine. It is OS 10.6.8 using FileMaker Pro 10.0v3 (not advanced) and browser is Safari 5.0.5. It is due for the latest large software update which I've held back as I don't want it to suffer the same problem.

      Workaround

      None

        • 1. Re: Context menu in web viewer works incorrectly
          GlennJackman

          Can anyone suggest a fix for this?

          • 2. Re: Context menu in web viewer works incorrectly
            TSGal

            Glenn Jackman:

            Thank you for your post.

            Can you provide the specific URL and links you are trying to access?  The exact steps you are taking may help narrow down the cause.

            TSGal
            FileMaker, Inc.

            • 3. Re: Context menu in web viewer works incorrectly
              GlennJackman

              Every single link on the web. This behaviour (at least on my Mac) applies to everything. Whereas before if I right clicked a link on a web page within a webviewer and selected 'open link in new window' the destination page of the link would open. Now the page that opens is the same originating page I am viewing in the web viewer.

              If this is not behaviour that other people are having it must presumably be my Mac, but I can't find anything which controls this behaviour.

              The same behaviour applies if I right click an image on any web page in web viewer and select 'open image in new window'. The image doesn't open in a new window but instead the original page opens.

              Thanks TSGal for any help you can offer

              • 4. Re: Context menu in web viewer works incorrectly
                TSGal

                Glenn Jackman:

                Thanks for the clarification.

                I am able to duplicate the problem with FileMaker Pro 10 and FileMaker Pro 11 on Mac OS X 10.6.8 and Mac OS X Lion 10.7.1, respectively.  The new window opens the same originating page as the Web Viewer.

                On Windows 7, XP and Vista, the correct page is displayed in Intenet Explorer.

                On a side note, if you take the context menu option "Copy Link", the correct link is copied which you can then paste into the browser window.

                I have forwarded your posts along with my findings to our Development and Testing departments for further review.

                TSGal
                FileMaker, Inc.

                • 5. Re: Context menu in web viewer works incorrectly
                  TSGal

                  Glenn Jackman:

                  I apologize for the late reply.

                  Our Testing team confirmed this was reported previously (not on the forum).  The matter was sent to Development previously.  No other information is avaiable at this time.

                  TSGal
                  FileMaker, Inc.