11 Replies Latest reply on Feb 1, 2012 8:42 AM by TSGal

    Copy in Preview mode fails in Snow Leopard

    LaurenNaslund

      Summary

      Copy in Preview mode fails in Snow Leopard

      Description of the issue

      FileMaker 9, 10, and 11Mac OS X 10.6.3 Performing a Copy in Preview mode randomly fails, leaving an empty Clipboard, or, character spacing in the copied image is deranged, with large gaps and overlapping characters. I've reproduced this in a simple database with a gray background rectangle and text in Tahoma. If you'd like to give it a try, let me know and I'll send the database. This problem does not occur in Mac OS X 10.5 or 10.4, and it does not occur in FileMaker Pro 8 in 10.6.3.

        • 1. Re: Copy in Preview mode fails in Snow Leopard
          TSGal

          Lauren Naslund:

           

          Thank you for your post.

           

          Since I'm unable to replicate the problem, first try recovering the file.  That is, close the file, pull down the File menu and select Recover.  Select the file and recover.  When finished, open the Recovered file and see if the problem persists.  If so, then I would like to see the file.  I have sent you a private message (top of this page - right side - envelope icon just below the blue horizontal bar) with instructions where to send the file.

           

          TSGal

          FileMaker, Inc.

          • 2. Re: Copy in Preview mode fails in Snow Leopard
            philmodjunk

            I don't have a Mac--let alone version 10.6, but the phrase "character spacing in the copied image is deranged, with large gaps and overlapping characters" has me wondering if there might be a font issue on your computer. Numerous reports have been posted here that traced back to this Snow Leopard specific issue. If it is a font issue, it may fail for you but work correctly for TSGal.

            • 3. Re: Copy in Preview mode fails in Snow Leopard
              LaurenNaslund

              That was my first suspicion, but the problem occurs with different fonts, including TrueTypes that come with the OS, and on different computers. Only some of the copied previews have bad spacing, and only some fail to copy. Different records fail to copy each time the test is run. 

               

              Thanks,

              Lauren Naslund

              Paradise Partners, Inc.

              • 4. Re: Copy in Preview mode fails in Snow Leopard
                TSGal

                Lauren:

                 

                Thank you for sending in your file.  I am definitely able to replicate the problem.

                 

                I can confirm this only occurs with Snow Leopard, as it works perfectly with Leopard (10.5.x).

                 

                I have forwarded your file along with my findings to our Development and Software Quality Assurance (Testing) departments for review and confirmation.  When I receive a reply, I will let you know.  The only workaround I see at this time is to revert to Leopard OS, which I know may not be feasible.

                 

                TSGal

                FileMaker, Inc.

                • 5. Re: Copy in Preview mode fails in Snow Leopard
                  philmodjunk

                  I'm asking the obvious here, but hate to assume somthing.

                   

                  This has been confirmed for more than just one file?

                   

                  If so, it's one more for the Known Bug List.

                  • 6. Re: Copy in Preview mode fails in Snow Leopard
                    LaurenNaslund

                    Yes. The first file was a solution I created for a client. This problem appeared when they upgraded to Snow Leopard. I created a second file (from scratch) that contained only the tables, fields and a script required to replicate the problem.

                     

                    Lauren Naslund

                    Paradise Partners, Inc.

                    • 7. Re: Copy in Preview mode fails in Snow Leopard
                      LaurenNaslund

                      Any news?

                       

                      Thanks,

                      Lauren Naslund

                      Paradise Partners, Inc.

                      • 8. Re: Copy in Preview mode fails in Snow Leopard
                        TSGal

                        Lauren Naslund:

                        I apologize for the late reply.

                        Our Testing department has confirmed the problem by running the script and performing the steps manually.  It has been forwarded to Development for further review.  No action available at this time.

                        TSGal
                        FileMaker, Inc.

                        • 9. Re: Copy in Preview mode fails in Snow Leopard
                          5104919325FTN

                          Someone mailed me today about the same problem, and with following configuration :

                          os x 10.6.6. with fmp 8.5

                          So, even this possibility for printing problems is a dead end.

                          But I always found this way of printing odd.

                          As I answer to you, hi TSGal, by the way :-)

                          • 10. Re: Copy in Preview mode fails in Snow Leopard
                            joedu

                            Hey guys. Late to the party, but just experienced this exact same issue, on Snow Leopard and FMP 11. One field refused to be copied in certain records only. Manually selecting and copying the field worked fine. It was the script that failed, and again on just a few records. Most copied fine.

                            I tried a few things, including using an applescript (key code 8 with command down) to select and copy, still no dice.

                            Not sure exectly what the problem was but it now works. It was one of two things (or both):

                            1) The field in question was actually a direct field (text) from a related file. I changed it to a calculation field, with the calculation being simply the field from the related file.

                            2) I deleted the field from the layout and placed it again.

                            Done.

                            One other thing I did, since I feared the font issue. I am perpetually confused with the way FMP handles fonts, with the "set input method" found in the Inspector. The field in question in the file that held the original data, received that data from a manual "copy-paste" from an external source. Being anal about appearances, the style from the external source would copy over and annoy me. I rememdy that with a command-z to set the style back. But since this copy issue, I changed the "set input method" of that field to synchronize with the field's font.

                            So really, one of three things. Does this shed any more light on the subject?

                            • 11. Re: Copy in Preview mode fails in Snow Leopard
                              TSGal

                              joedu:

                              Thank you for your post, and I apologize for the late reply.

                              There is no additional information from Testing about this issue.  However, I have forwarded your findings to our Development and Testing departments in hopes it provides insight into the cause.

                              TSGal
                              FileMaker, Inc.