2 Replies Latest reply on Nov 26, 2013 9:35 AM by TSGal

    Crash in 10.9 FMPA 12.5 in portal

    dhrowe10

      Summary

      Crash in 10.9 FMPA 12.5 in portal

      Product

      FileMaker Pro

      Version

      12.5

      Operating system version

      10.9

      Description of the issue

      Creating new portal copied some code and portal very slow / crash filemaker WITHOUT crash log. 

      File started in FMP11 then converted to 12.  Now between 10.9 and 12.5 it is crashing every couple of hours.  Biggest issue is that no crash log is created.  In the system log it just says..

      11/24/13 3:24:53.275 PM FileMaker Pro[5402]: FileMaker Pro(5402,0xa08851a8) malloc: *** mach_vm_map(size=402653184) failed (error code=3)
      *** error: can't allocate region
      *** set a breakpoint in malloc_error_break to debug

      11/24/13 3:24:53.385 PM com.apple.launchd.peruser.925985419[184]: (com.filemaker.client.advanced12.30304[5402]) Exited with code: 6

      11/24/13 4:42:31.673 PM FileMaker Pro[7930]: FileMaker Pro(7930,0xa08851a8) malloc: *** mach_vm_map(size=201326592) failed (error code=3)
      *** error: can't allocate region
      *** set a breakpoint in malloc_error_break to debug


      Then throw away the files, put in new masters.. work for a little bit and again bang..

      Its happening on a relatively simple layout...trying to set up a portal on a Tab.

      Steps to reproduce the problem

      Open file, do anything on layout, which was not very responsive, in layout mode, eventually crash.

      Reverted back to master file from a day ago and problem went away.  Only can think I copied a corrupt / graphic?

      Exact text of any error message(s) that appear

      11/24/13 4:42:31.673 PM FileMaker Pro[7930]: FileMaker Pro(7930,0xa08851a8) malloc: *** mach_vm_map(size=201326592) failed (error code=3)
      *** error: can't allocate region
      *** set a breakpoint in malloc_error_break to debug

      Workaround

      Reverted back to master file from a day ago and problem went away.  Only can think I copied a corrupt / graphic?

        • 1. Re: Crash in 10.9 FMPA 12.5 in portal
          philmodjunk
               

                    Only can think I copied a corrupt / graphic?

               That's certainly possible, I've had a corrupt graphic crash FileMaker in the very distant past.

               Is the graphic in a container field? Are there any PDF's in container fields on the layout in question?

          • 2. Re: Crash in 10.9 FMPA 12.5 in portal
            TSGal

                 dhrowe10:

                 Thank you for your post.

                 Since the original file works, you may have a bad layout or bad file.  To see if it is the layout, create a new layout (do not duplicate), and create the same fields and objects on the new layout (do not copy and paste).  If you cannot duplicate the issue using the new layout, then your original layout is damaged.  If this is the case, delete the original layout and continue using the new layout.

                 If the problem still exists in the new layout, then your file may be damaged.  Export the new data from the damaged file, and import it into the original file.

                 Let me know if you are able to further narrow down the possible causes.

                 TSGal
                 FileMaker, Inc.