AnsweredAssumed Answered

Cursor placement inconsistent from field to field in FM13 - worked fine in prev versions

Question asked by AndrewEskind on Sep 30, 2014
Latest reply on Sep 30, 2014 by philmodjunk

Summary

Cursor placement inconsistent from field to field in FM13 - worked fine in prev versions

Product

FileMaker Pro

Version

Filemaker Pro 13.0 v3

Operating system version

Windows 7

Description of the issue

I just installed FMP 13 having developed my FM application beginning with FM9 and having migrated without issue thru 10, 11, and 12 in recent years.

The application has a couple dozen layouts developed over the years with tools current at the time of development.

I use the application 365 days annually and am well acquainted with its behavior.  (It is also webserved via triple8.net, but have not YET updated the online copy with FMP 13 copy).

The issue:  the cursor is positioned IN FRONT of (left side of) characters instead of to the right edge (aka behind) characters during data entry or edit of existing values.  This behavior happens regularly in SOME data entry fields on SOME layouts - not everywhere.

Also - in other fields the cursor positions an extra space farther to the right of current character instead of snug up against right edge.

In both of the above situations, I can adapt my expectations and accomplish desired results.  I have never seen this in previous versions of FM (nor in any other computer context).

My hunch is that FM13 is for some reason fussier about the size or placement of some data entry fields created with tools in previous versions.   Otherwise I have no idea what's going on with this, but it is annoying.  If this behavior propagates to the public version served by triple8.net, that will be cause for even more concern.

Steps to reproduce the problem

I tried to illustrate this with screen shot, however screen capture doesn't capture the cursor position.   Perhaps a remote session would illus.

Expected result

am able to workaround, but would be confusing to public user of my data

Exact text of any error message(s) that appear

no error messages generated

Configuration information

No other changes to this computer.  Web browser & other activities all work without exhibiting this behavior

Workaround

workaround is for me to ignore inconsistent cursor placement and rely on act of faith that what I type will go where it should.

Imagine in the screenshot below the cursor placed one extra space to the right of the last character typed.   As if there's a blank character - only there isn't - it's a continuous string.
Before FM13, this layout has been used roughly 1500 times without this issue.

fmprob-wheres_cursor.jpg

Outcomes