AnsweredAssumed Answered

Cursor symbol position deviates from real cursor position during text entry under Win 7 and Win 8.1

Question asked by TorstenBernhard_1 on Feb 27, 2015
Latest reply on May 9, 2017 by TSGal

Summary

Cursor symbol position deviates from real cursor position during text entry under Win 7 and Win 8.1

Product

FileMaker Pro

Version

13.0v5

Operating system version

Windows 7 Pro 64 bit and Win 8.1 Pro 64 bit

Description of the issue

Set filemaker zoom to 100%.
When entering text in a text field, the cursor symbol gets out of sync with the real cursor position, either trailing behind or moving ahead, depending on letter width.

Users get confused and the number typos increases.

This also happens when typing in a text box in layout mode.
Setting the scaling to 100% in Windows Control Panel/Appearance and Personalisation/Display solves the issue, but in very unpleasant way: everything on the screen is too small for easy reading, including FileMaker's toolbar.
Setting FileMaker zoom to something different from 100% also solves the issue.
.

Steps to reproduce the problem

Set Windows scaling to 125% (best for my screen)
Set FileMaker zoom to 100%
Type in text field in browse mode or type in text box in layout mode.

Expected result

Cursor symbol always be shown at real cursor position.

Actual result

Cursor symbol moves away from real cursor position. It moves ahead or trails behind, depending on letter width. This adds up in a line.

Exact text of any error message(s) that appear

none

Configuration information

Hardware: Microsoft Surface Pro
System setup is 2 days old. Only FMP 13.0v5 as additional SW was installed
System and FMP are set up in English language.

Workaround

A: Changing windows screen scaling to 100%
B: Setting FileMaker zoom to something different from 100%.

Solution A negatively impacts readability of everything on screen, including FMP toolbar.
Solution B negatively impacts ergonomics of solutions and requires modification of layouts.

IMG_1484.JPG

Outcomes