3 Replies Latest reply on Oct 25, 2010 2:42 PM by philmodjunk

    Data does not appear in preview mode

    kashaev

      Summary

      Data does not appear in preview mode

      Product

      FileMaker Pro

      Version

      11.0v2

      Operating system version

      OS X 10.6.4

      Description of the issue

      I have created a report that looks up information from a master table and inputs the information for editing within the current project table.  All the information fills the fields in browse mode but when I switch to Preview mode all I get are empty field boxes with no information.  If I go to the master table and view the information and switch to preview everything is fine and it all shows up.  I've created a new layout thinking that maybe the layout has a problem...but nope it does it too.  Any thought?

        • 1. Re: Data does not appear in preview mode
          philmodjunk

          How many records are in your found set? Any chance the first record is a blank record?

          When you enter preview mode, FileMaker assumes you are going to use the "Records being Browsed" option to print or preview your layout and thus puts record 1 on page 1 of the preview. To see all the records in your preview, you may need to click the book icon to move through the preview one page at a time much like you use it to move through records when in browse mode.

          If you only want to see the current record in Preview, you can use a script or options from the Records menu to isolate this record in a found set of just this record before you preview it.

          • 2. Re: Data does not appear in preview mode
            kashaev

            Thanks...That does seem to be the issue.  I guess I should have realized that.  (Doh?!)

            • 3. Re: Data does not appear in preview mode
              philmodjunk

              It's obvious after the fact, but not when you first encounter it. While not at the top of my list, I've long thought, adding the Records being Browsed / Current record option as a parameter to the Enter Preview Mode step would be useful.