2 Replies Latest reply on Aug 19, 2013 7:38 AM by Fei-LingTseng

    Date format in the inspector glitching out + odd date format hyphen separator

    Fei-LingTseng

      Summary

      Date format in the inspector glitching out + odd date format hyphen separator

      Product

      FileMaker Pro

      Version

      12 Advance

      Operating system version

      Windows 7 x64

      Description of the issue

      What I wanted to do was to change timestamp format on a field to display the same format between timestamps created by an FM application (08/25/2013) versus FM Go (2013-08-25). I want all timestamp fields to display like the FM Go. In the process, I came across two issues.

      First, the area in the inspector where you can define custom orders of day/month/year and symbol separators were fine when I started but as I kept making changes the dropdown fields started either 1. collapsing to the point that options were overlapping each other, or 2. becoming so tall that options would fly beyond the height of my screen. I did not catch a screen shot of the former but please see attached image for examples of the latter.

      Second, the hyphen option looks completely goofy. Instead of the short hyphen, it is using the longer em hyphens which is incorrect. Not sure if there's an option to define your own symbol, but wasn't able to find it. Please see attached image again for an example of the longer hyphen.

      I could easily revert to non-formatted fields, but then the timestamps won't look the same because the timestamps produced from different platforms are differently formatted depending on which platform you see it on.
      I just want them to be "YY-MM-DD hh:mm AM" no matter what platform you're on.

      Any clues on this issue would be much appreciated.

      Edit: Changed title and a couple of sentences to make issues more clear.

      Steps to reproduce the problem

      No idea what I did exactly that was unusual. I was just defining the date format in the inspector when it started happening.

      Expected result

      Dates that look like:
      2013-08-25 12:00 AM

      Actual result

      Dates that look like:
      2013--08--25 12:00 AM (long hyphens)

      Configuration information

      I'm implementing timestamps triggered by script when certain fields are edited. That is what is creating the dates in the field.

      Workaround

      There might be a way for me to force a certain format to be output on the script level, but this doesn't change the format of already existing timestamps until they are changed again by the script.

      Regardless, the way the dropdown is behaving is absolutely bizarre. I don't think it should be doing that.

      FM_glitches_in_inspector_composite.jpg

        • 1. Re: Date format in the inspector glitching out + odd date format hyphen separator
          philmodjunk
               

                    What I wanted to do was to change timestamp format on a field to display the same format between timestamps created by an FM application (08/25/2013) versus FM Go (2013-08-25).

               I'm not sure what you mean by that. I get the same format for a timestamp on a given layout whether it is viewed on my iPhone or my computer. The default format that I see uses the / date delimitter rather than -.

               With regards to the problems with the Inspector, I have not observed that behavior here. I suggest trying this with a brand new file with a single timestamp field to see if you get the same behavior. This test will help check to see if there might be a problem with your layout or the file.

          • 2. Re: Date format in the inspector glitching out + odd date format hyphen separator
            Fei-LingTseng

                 Hi Phil,

                 Thanks for your response. Here's the update:

                 Re: Inspector

                 The glitch hung around for a full day (Friday), even through reboots and new files. However, today when I launched FM, it seems fine. Bizarre. Solved for now.

                 Re: Timestamp format

                 I found a "secret" workaround. But first just to clarify the issue for the future: This comes up when wanting to change format to something other than what the host computer. My computer is MM/DD/YYYY, and FM on my computer will display it like that with fwdslash (/) delimiters. However, my phone is DD/MM/YYYY, and there it also prefers to show it with short hyphens (-). I just wanted to make a custom format on the field so it always would display with DD first, and with short hyphens. Since my computer is MM first, one needs to use the "Custom" date setting to rearrange the MM and DD. Within that, the dropdown menu of delimiters only has the long hyphen available, and it serously makes dates look goofy.

                 However the workaround is to just use the dropdown field as a regular field, and TYPE the hyphen in. Any symbol you type in there will be used as the delimiter.