7 Replies Latest reply on Oct 30, 2013 10:15 AM by rdfoto

    Date format showing Japanese figures for year

    FrankFarmer_1

      Summary

      Date format showing Japanese figures for year

      Product

      FileMaker Pro

      Version

      10.0v3

      Operating system version

      Mac OS 10.7.5

      Description of the issue

      When displaying a date with a format where the month is spelled out (either abbreviated or full), the year appears with Japanese characters instead of four digits.
      For example, in a report layout where I want the current date to appear as, say, Jan 10, 2013
      it shows up as Jan 10, ##25 (where ## are Japanese characters, and heaven knows where the 25 comes from).
      When I go to Layout mode to specify the date format, the only options I'm given are:
      03.12.25
      2003.12.25
      Dec 25, ##15
      December 25, ##15
      and so on. 
      No chance of a proper four digit year when the month is spelled out.
      I am not Japanese!!

      This problem just started happening suddenly. In the past, it's been OK (tho' I do recall this occurring before -- don't recall how it was corrected). I've been using FM Pro for many years.

      Steps to reproduce the problem

      I've tried changing the date format several times, to no avail. This is very frustrating!

      Expected result

      Jan 10, 2013

      Actual result

      Jan 10, ##25  (where ## are Japanese characters, and the 25 is, for some reason, 25).

      Exact text of any error message(s) that appear

      No error message appears.

      Workaround

      For now, I'm using the yyyy.mm.dd format, but I'd prefer a mmm dd, yyyy format.