4 Replies Latest reply on Jun 18, 2012 1:44 PM by philmodjunk

    Date formats become mixed and cause failure in FMP 12

    SEMJ

      Summary

      Date formats become mixed and cause failure in FMP 12

      Product

      FileMaker Pro

      Version

      12

      Operating system version

      Mac OS X 10.7

      Description of the issue

      I am using the latest demo version before buying version 12.

      I have moved a database developed in FM 11 Advanced which otherwise worked fine.

      I have a drop down box based on a value list of dates generated by a relationship dependent on a unique identifier of subjects. This worked fine in FM 11 but returns a "?" in version 12. Some playing has got it to produce dates in US format but I am based in the UK and all other dates in the database are in DD/MM/YYYY format. This causes a failure based on dates being in the incorrect format. I can see no way to fix this manually and cannot be bothered with a workaround. I will stick with version 11 until 12 is fixed.

      Expected result

      Dates in DD/MM/YYYY format throughout the database as MM/DD/YYYY format causes failure.

      Exact text of any error message(s) that appear

      Generic error message telling me that the date is not in format DD/MM/YYYY and asking me to revert the field to previous state.

      Workaround

      Further calculation field to try to change format of dates back to UK format may fix it I guess.