0 Replies Latest reply on Aug 31, 2012 11:35 AM by jbarnum

    DATEFORMAT attribute in XML Web Publishing header does not match actual date format of data

    jbarnum

      Summary

      DATEFORMAT attribute in XML Web Publishing header does not match actual date format of data

      Product

      FileMaker Server

      Version

      12.0.1.150

      Operating system version

      Don't know

      Description of the issue

      As you can see in the screenshot, the XML publishing has this element:



      However, the actual timestamp value is "08-08-2012 21:07:07", which does not match the advertised date format. This makes it impossible to parse the date value, other than simply guessing at what the correct format might be.

      Steps to reproduce the problem

      This is difficult for me to reproduce because this is for a client in the Netherlands, and it appears that it is using their date format. My dates in the U.S. are appearing as MM/dd/yyyy, which does not cause a problem.

      Expected result

      Either 1) DATEFORMAT should say "MM-dd-yyyy" or 2) the data should be 08/08/2012 21:07:07.

      Actual result

      DATEFORMAT is "MM/dd/yyyy", which does not match the data value of "08-08-2012"

      Exact text of any error message(s) that appear

      N/A

      Configuration information

      I don't know the customer's configuration

      Workaround

      In my parsing code, change the hyphens to slashes and cross my fingers and hope that everything else is fine, and that the MM and dd are in the same order as expected.

      Screen_shot_2012-08-31_at_8.26.36_AM.png