7 Replies Latest reply on Jun 18, 2015 10:06 PM by oliversteffe

    dates in scripts are wrong

    oliversteffe

      Summary

      dates in scripts are wrong

      Product

      FileMaker Pro

      Version

      14.0.1 Advanced

      Operating system version

      Mac OS X

      Description of the issue

      Scripts are inserting Dates in wrong order!

      Steps to reproduce the problem

      Create a script wich sets a date out of variables like

      "*." & $SuchMonat & "." & $SuchJahr

      and let set the output into a date field.

      Expected result

      For  $SuchMonat = 6 and $SuchJahr = 2015
      I expect *.06.2015
      I'm in Germany and it worked in FM13

      Actual result

      For  $SuchMonat = 6 and $SuchJahr = 2015
      Result is 06.*.2015

      Exact text of any error message(s) that appear

      Whole Solution is affected!

      Workaround

      NONE!

      Bildschirmfoto_2015-06-12_um_17.19.56.png

        • 1. Re: dates in scripts are wrong
          TSGal

          Oliver Steffe:

          Thank you for your post.

          I am unable to replicate the issue with FileMaker Pro 14.0.1 under Mac OS X 10.10.3.  Whenever I set the field to the value, it always displays the asterisk first.  The Data Viewer also shows the correct value.

          If you do not use the variable $SuchZeitraum, but instead set the field Plan_Datum to the calculation, does it then work properly?

          As a possible workaround, try setting Plan_Datum to:  $SuchMonat & "." & SuchJahr

          This will search for all records in that month and year.

          TSGal
          FileMaker, Inc.

          • 2. Re: dates in scripts are wrong
            philmodjunk

            Might be an issue with locality settings. To test, TSGal may need to replicate the language and/or locality options that Oliver Steffe is using.

            • 3. Re: dates in scripts are wrong
              oliversteffe

              Hi,

              this works for me

              As a possible workaround, try setting Plan_Datum to:  $SuchMonat & "." & SuchJahr

              thanks.

              But there is a Problem in localization, as you can see in the screenshot.

              • 4. Re: dates in scripts are wrong
                TSGal

                Oliver Steffe:

                It appears that the file was created on an English system, as this would retain the English system format.

                Create a new database file under German system with a Date field "Date", and format the Date field for 25.12.2003.  Then, add a Calculation field "DateCalculation" with the formula: Date & " Text".  Enter a record and enter 18.06.2015.  You will now see the calculation display "18.06.2015 Text"

                TSGal
                FileMaker, Inc.

                • 5. Re: dates in scripts are wrong
                  oliversteffe

                  Thanks for the information.

                  Why does it matter on wich language the database was created?

                  A date field is a date fiel is a date field and the value stored in it should be interpreted correctly for the client.

                  What should I do when I have a multi language installation with users wich have to use different languages?

                  From my point of view this is a real bug.

                  • 6. Re: dates in scripts are wrong
                    TSGal

                    Oliver Steffe:

                    Save a clone of the file, as this will set the region setting for the database file.  To insure this works properly, enter a date, and the calculation will display properly.  Then, delete the record, and import from the original file.

                    TSGal
                    FileMaker, Inc.

                    • 7. Re: dates in scripts are wrong
                      oliversteffe

                      This may take a while, because it is a huge effort.

                      There are about 50 tables in my solution and the size of the database is about 3 GB.

                      Saving a clone and import the data is not a good solution for me.