AnsweredAssumed Answered

Deployment of FileMaker Pro 11 via MS DeploymentWorkbench 2010 possible bug

Question asked by ToddFryar on Feb 17, 2011

Summary

Deployment of FileMaker Pro 11 via MS DeploymentWorkbench 2010 possible bug

Product

FileMaker Pro

Version

11 v1

Operating system version

XP Pro

Description of the issue

I am attempting to deploy FileMaker Pro 11 via MS DeploymentWorkbench 2010.  After spending about 5 hours on the phone with Microsoft, they asked me to contact you to report a possible bug in the installer.

In DeploymentWorkbench 2010, when performing a silent install using either setup.exe or FileMaker Pro 11.msi, it appears that the install is immediately reporting that it has completed, when in fact it is just beginning.  What then happens is any subsequent Task Sequence fails because the MS installer detects that another installation is still in progress.  We repeated this behavior multiple times.

Steps to reproduce the problem

Using MS Server 2008 R2 64-bit
Installed MS Deployment Services, patched to latest release
Installed DeploymentWorkbench 2010, patched to latest release
Imported multiple applications for deployment
For FileMaker Pro v11.0 I tried the following syntax:
- setup.exe /S /v/qn
- "\Files\FileMaker Pro 11.msi" /qn

I then renamed the .msi to FileMakerPro11.msi and tried the following syntax:

- \Files\FileMakerPro11.msi /qn

Expected result

The installation should start and take a minute or two, showing a progress bar.  When it completes, the next Task Sequence should start and begin installing the next application, which is the update to v3.

Actual result

The initial installation begins but appears to immediately report that it has successfully completed (2 seconds according to the logs) so the next Task Sequence begins.  If the next sequence is an application install, it fails because it detects that one is still in progress.  It does not matter what sequence follows the FileMaker Pro v11.0, the behavior is the same, the next sequence begins too quickly because it thinks the install has completed.

Workaround

There is no workaround at this time.

Outcomes