1 2 3 Previous Next 35 Replies Latest reply on May 12, 2015 2:43 AM by marc.maker

    disappearing shortcut for "Layout Mode"

    seevogel

      Summary

      disappearing shortcut for "Layout Mode"

      Product

      FileMaker Pro

      Version

      13.0v1

      Operating system version

      OS X 10.9.1

      Description of the issue

      after a while of using FileMaker the shortcut for Layout Mode disappear.
      This does not happen with any other shortcut.

      Maybe it has to do with following circumstance:

      In "System Preferences/Keyboard/Shortcuts/AppShortcuts" I have defined some additional shortcuts for FileMaker.

      I use command-L for "Layout Setup..." because there is no regular shortcut to open the Layout Setup window in Layout Mode.

      I also have defined some other shortcuts to open and close the Script Debugger Window, Data Viewer, etc (see screenshot)

      Steps to reproduce the problem

      it disappears after some hours

      Workaround

      going to Layout Mode using the Cursor/Mouse/Trackpad

      shortcuts.png

        • 1. Re: disappearing shortcut for "Layout Mode"
          RickWhitelaw

               Well, command-L is the keyboard shortcut for entering layout mode.  You've apparently reassigned that shortcut to perform something else so of course it's no longer available for its original default purpose.

          • 2. Re: disappearing shortcut for "Layout Mode"
            seevogel

                 The shortcut does not disappear instantly but after a while (some hours after using).

                 This did not happen with FMP12, FMP11 or FMP10.

                 Things should work or should not work, but not changing behavior randomly.

                 It should work with the standard features given by the OS (so I think).

                  

                 The whole menu structure seems not to be 100% stable if using custom menus.

                 I have crashes daily. Even on systems where I do not use additional shortcuts from the OS.

                 This is getting better immediately if deactivating custom menus.

                 Even if the custom menu has minimal changes only.

                  

            • 3. Re: disappearing shortcut for "Layout Mode"
              RickWhitelaw

                   Hmmm . . . I use Custom Menus extensively and have never had a problem such as you describe. Have you tried running Recover to see what it reports?

              • 4. Re: disappearing shortcut for "Layout Mode"
                fmdataweb

                     I've also just encountered the issue of the shortcut for Layout Mode disappearing with FileMaker Pro Advanced 13.0v1 on Mac OS X 10.9.1.

                     Very strange - never seen this before. Closing the file and opening it does not restore the shortcut.

                • 5. Re: disappearing shortcut for "Layout Mode"
                  seevogel

                       I had deleted the shortcut "Command-L" from the system-preferences a week ago.

                       But the shortcut for "Layout Mode" had disappeared again a few times.

                        

                       So I think: The disappearing of "Command L" for "Layout Mode" has nothing to do with defining additional commands from system preferences.

                        

                       After quitting FileMaker 13 and launching it again (without opening any file) the shortcut is back.

                       Intentionally that command is changing if going to "define Database".

                       It becomes the command for changing a field to a calculation field.

                       Maybe it does not return back if closing the define database window under some circumstances…

                        

                  • 6. Re: disappearing shortcut for "Layout Mode"
                    RickWhitelaw

                         I can't explain this exactly, but given the frequency of use of Command-L to go to layout mode I would advise against reassigning it to anything else anywhere . . . OS preferences OR within FileMaker. As far as reassigning the command to a different function when the Define Database window is open, well I can't say that would work and retain the go to Layout mode while not in the Define Database window.  And then there's "why"? Changing a field definition to calc doesn't require a lot of work without a shortcut.

                    • 7. Re: disappearing shortcut for "Layout Mode"
                      seevogel

                           There are other commands disappearing also.

                           In Scripteditor:

                           command-D

                           command-S

                            

                           So, in scripting mode it is always the regular menu set and no custom menu set involved.

                           it is a fresh FMP-13 installation (installed some hours ago)

                      • 8. Re: disappearing shortcut for "Layout Mode"
                        TSGal

                             All:

                             Thank you for your post.

                             This issue has been previously reported, and it appears to be a Mac OS X 10.9.x issue, and Apple is aware of it.  For another thread of this issue, see:

                        Layout Mode keyboard shortcut disappears

                             This is what I posted to that thread earlier today:

                             Our Testing team has informed me this is an Apple Mac OS X 10.9.x (Mavericks) issue.  Duplicate Record (Command-D) and Restore Last Find (Command-R) shortcuts may also be missing.  In one report, going to Manage Database and scrolling in the dialog might cause the issue, and going back into Manage Database and scrolling unlocks the shortcuts.  This same tester was only able to reproduce on a trackpad and MagicMouse, but could not reproduce with mouse wheel.  This information has been forwarded to Apple.

                             I'll continue to keep everyone updated as information becomes available.

                             TSGal
                             FileMaker, Inc.

                        • 9. Re: disappearing shortcut for "Layout Mode"
                          philmodjunk

                               An entry in the Known Bugs List has been linked to this Issue Report. Any Comments/Questions/Suggested Corrections should be posted here or in a new thread. Please do not post such comments to the Known Bugs List thread.

                          • 10. Re: disappearing shortcut for "Layout Mode"
                            JonJ

                            I run FM 13 on a MacBook Air running Yosemite. I also have FM 12 installed for a few legacy clients.

                            If I have FM13 open, and then open FM12 (even without then proceeding to open a database) ⌘L instantly disappears from FM13's menu. I have to close both FM12 and 13, then reopen 13 to get the menu shortcut back.

                            Hope this helps.

                            Jon.

                            • 11. Re: disappearing shortcut for "Layout Mode"
                              Mantic

                              I have experienced the missing shortcut and can confirm that the advice from JonJ has certainly worked for me so far (ie close FM13, start FM12, close FM12, start FM13).

                              • 12. Re: disappearing shortcut for "Layout Mode"
                                Mantic

                                I've now noticed that the shortcut for saving an edited script (command S on a Mac) vanishes along with the layout mode shortcut - screenshots attached. I can confirm that restarting FM13 brings the shortcuts back, that no Custom Menus are installed and that the bug doesn't appear to be related to a specific file / computer.

                                • 13. Re: disappearing shortcut for "Layout Mode"
                                  SlaterKing

                                  I've the same thing, on 10.10.1 and FMP 13.0v4

                                  • 14. Re: disappearing shortcut for "Layout Mode"
                                    DavidRemsen

                                    This happens to me with my Filemaker Pro Advanced 13.0v4.  I can recreate this consistently.  I simply go to Manage Database either under the File->Manage Menu or through the Cmd-Shift-D shortcut.   I made a screencast of it at 

                                    https://flic.kr/p/pqdLxu

                                    See for yourself,

                                    Dave Remsen (dremsen@mbl.edu)

                                    1 2 3 Previous Next