4 Replies Latest reply on Feb 9, 2010 2:42 PM by philmodjunk

    duplicated layout name not updating in the script step

    val360_1

      Summary

      duplicated layout name not updating in the script step

      Description of the issue

      FileMaker Product(s) involved:FileMaker Pro 10v3, FileMaker Server 10v2.206 Operating System(s) involved:Mac 10.6.2 Detailed description of the issue:http://demo.360works.com/layoutnamebug.png Exact steps to reproduce the issue:http://demo.360works.com/layoutnamebug.png Expected Result:Correct layout name Actual Result:Stale layout name Exact text of any error message(s) that appeared:N/A

        • 1. Re: duplicated layout name not updating in the script step
          mrvodka
            

          Hiya doing Val?

           

          Been a few months. :)

           

          Out of curiosity, have you tried rebooting the client box? I am wondering because sometimes I get these kind of strange things with Windows and it requires a reboot of my box to fix it. A simple exiting of Pro and reopening doesnt fix it.

           

           

          • 2. Re: duplicated layout name not updating in the script step
            LaRetta_1
               And I get them sometimes and they look broken (right after I specify a layout).  But when I save and exit the script and go back in, it has properly changed.
            • 3. Re: duplicated layout name not updating in the script step
              TSGal

              val360:

               

              Thank you for your post.

               

              I have tried this with Windows XP SP3, Mac OS X 10.5.8, and Mac OS X 10.6.2, and I have been unable to replicate the problem.  I have tried to have a second user modify the same script, but it won't allow me while it is being edited on the first machine.  I've checked our existing issues database and I don't see anything listed.

               

              The replies from mr_vodka and LaRetta come from experience, and I would definitely be interested if anyone is able to replicate this consistently, but I'm assuming this is one of those problems that occurs randomly and rarely.

               

              val360:  By your user name, I'm assuming you work for 360Works, and you have that plug-in installed.

               

              mr_vodka and LaRetta:  When you encountered this problem, did you have any plug-ins installed?  Custom menus?  If you can't remember, that's fine.  Were you working with the file a long time before this occurred?  I'm just trying to gather information and find some commonality so I can forward this as a possible problem.

               

              TSGal

              FileMaker, Inc. 

              • 4. Re: duplicated layout name not updating in the script step
                philmodjunk
                  

                I think I saw this just recently...

                 

                I renamed a layout, but did not save my layout changes and then opened up a script and started editing it. Naturally, any references to the renamed layout still showed the original layout name, but in the window behind my script editor, I could see the layout still in layout mode with the new layout name displayed. It confused me for a second until I realized that all I had to do was save my layout changes.

                 

                Is that what we're seeing here or is there more to it?