2 Replies Latest reply on Apr 23, 2013 12:50 AM by tomasd

    Editing of tab control after conversion crash

    tomasd

      Summary

      Editing of tab control after conversion crash

      Product

      FileMaker Pro

      Version

      12v3

      Operating system version

      Windows XP

      Description of the issue

      I have converted database from FM11. One layout has tab control with "empty" labels (containing only white spaces). If I want edit this tab control in Filemaker 12 layout editor, the client crashes.

      Steps to reproduce the problem

      Create tab control with only whitespaces in label, convert it to FM12 and edit tab control in layout manager.

      Expected result

      Fm 12 client should not crash.

      Actual result

      Fm 12 client will crash after 10 seconds.

      Exact text of any error message(s) that appear

      None

      Configuration information

      Fm12v4 server + Fm12v3 client on Windows XP

      Workaround

      Delete tab control before conversion.

        • 1. Re: Editing of tab control after conversion crash
          philmodjunk

               Using FIleMaker 12.03 on Windows XP, I am unable to reproduce this crash. I created a brand new test file in FileMaker 11v3 with no tables, just a tab control. I tried this with two panel tab controls, one panel had a text label the second tab had no label. I was able to convert the file and then modify the tab control in tab control set up after conversion.

               I also tried this with a tab label of several space characters and it also did not crash.

               Let me know if you spot any differences between what I did to test this and your own expriences.

               This suggests the possibility that your original file may have had some latent file damage that only came out of hiding post conversion when you tried to edit the tab control set up.

               You might try running a recover in FileMaker 11 on the file and then converting the recovered copy to see if you get different results.

          • 2. Re: Editing of tab control after conversion crash
            tomasd

                 Today, I tryed to edit tab panel and everything works as you say. The layout was not corrupted. Yesterday, I was testing printing and there were some hangs and errors before (but it is different topic). I thought, that simple restart should be enough, but the client was not in proper state and it caused this behaviour. Restart of operating system helped.