6 Replies Latest reply on Jul 13, 2011 1:20 PM by KevinDunajski

    External Authentication breaks after 11v3 update

    user14401

      Summary

      External Authentication breaks after 11v3 update

      Product

      FileMaker Server

      Version

      11.0v3

      Operating system version

      Mac OSXS 10.6.7

      Description of the issue

      We have a Mac mini server which was running FMS 11v2 on OSXS 10.6.7 quite happily using external authentication (from OD running on a separate machine running OSXS 10.6.6). We applied the 11v3 update and trouble started. Some users were able to log in and some could not. This is similar to one of the problems reportedly fixed by the update, and one that we experienced (on a different machine) with 11v1. After an uninstall of FMS and then reinstall, leaving it at 11v2 has restored full functionality.

      Steps to reproduce the problem

      Clean install of OSXS 10.6.7 on Mac mini. Install FMS 11 and all updates.
      Configure server to use  to OD fro another machine running OSXS 10.6.6.
      Configure server to require external authentication.
      Host some files that have some accounts that require external authentication.

      Expected result

      All users can login using external authentication

      Actual result

      Some users can login via external authentication, some can't.

      Exact text of any error message(s) that appear

      You are not authorized to access...

      Workaround

      Uninstall FMS and reinstall 11v2.

        • 1. Re: External Authentication breaks after 11v3 update

          David Tolson:

          Thanks for posting!

          Were the users unable to login via external authentication all part of the same group?

          Was this computer specific or account specific, i.e., did an account work on one computer and fail on another?

          TSBear
          FileMaker, Inc. 

          • 2. Re: External Authentication breaks after 11v3 update
            user14401

            Yes, all users unable to login were part of the same group, but that is because there was only one of them!

            We tried on more than one computer with the same results, so it was account-specific.

            David

            • 3. Re: External Authentication breaks after 11v3 update

              David Tolson:

              Since a full reinstall with v2 resolved the issue previously, would it be possible to try a full uninstall and reinstall using the v3 installer? Please check your inbox at the top of this page for a private message with additional information.

              TSBear
              FileMaker, Inc. 

              • 4. Re: External Authentication breaks after 11v3 update
                user14401

                The Mac Mini Server has not been available to experiment on, as it became a production machine, and is running quite happily with v2 with no login issues. Instead, we took a new machine (this time an iMac with a new 10.6.7 client OS install, and installed v3 from scratch. Unfortunately, we get the same results, i.e. v3 exhibits login problems. This iMac will not be taken away if you need us to run further trials

                We have done further tests and found that users with the same OD group membership get different results. A restart of the server will often resolve the problem for some and then cause the problem to appear for others. It just seems that FMS' version of who has what group memberships has holes in it and these holes vary. Once again, this exactly mimics problems we had with v1, which seemed to disappear with v2  and now they're back in v3. We would be quite happy sticking with v2, except that we need ODBC to be dependable, and v3 fixes a memory leak problem.

                David.

                • 5. Re: External Authentication breaks after 11v3 update
                  TSGal

                  David Tolson:

                  Try setting up a new test group with some new test accounts and see if they work.  If so, then try moving some of these problem accounts into the new group and see if they work.  I'm trying to isolate this down between groups and/or individuals.

                  TSGal
                  FileMaker, Inc.

                  • 6. Re: External Authentication breaks after 11v3 update
                    KevinDunajski

                    TSGal & Mr. Tolson:

                    Forgive me if I'm stating something that was already tested or is perhaps not relevant, but I've been following this thread because I experienced a similar problem after moving our server to OS 10.6.   I solved my problem by converting all our Open Directory groups and FileMaker External Access groups to all lower case.  If this has nothing to do with your own problem, I apologize again.  But on the off-chance it helps, I wanted to mention it.