10 Replies Latest reply on Jan 16, 2014 10:01 AM by philmodjunk

    Field cannot be placed on portal, or only by chance

    AnalogonEnterprise

      Summary

      Field cannot be placed on portal, or only by chance

      Product

      FileMaker Pro

      Version

      13.0v1

      Operating system version

      MacOs9.1

      Description of the issue

      Sometimes it is nearly impossible to place a field on a portal. Although the field is entirely placed inside the first row of the portal, it's data will only be shown once, not in each row of the portal as expected. This is the case if if the top/bottom position is equal to a field which works (i.e. which is shown in each row of the portal). After endless ttys of correcting the position, sometimes the field works, sometimes not.

      Steps to reproduce the problem

      see above

      Expected result

      Data is shown in each row of the portal

      Actual result

      data is only shown in the first row of the portal.

      Exact text of any error message(s) that appear

      none

      Workaround

      endless trying

        • 1. Re: Field cannot be placed on portal, or only by chance
          philmodjunk

               Sounds like the portal is not properly "owning" the field you are trying to place in the portal row. Using the position tab to position a layout object inside the portal row is usually the reason.

               The following steps usually work for me:

               If the object is already inside the borders of the portal row and not appearing in every row, drag it completely outside of the portal and release your mouse button.

               Drag the layout object until it is fully within the borders of the portal. Select the portal and tap an arrow key or two to "nudge" the portal a few pixels back and forth. If the portal owns the layout object, both will move when the portal is moved.

               Then use the various controls inf the Position tab to "fine tune" its placement within the portal row.

               For More Information see:     Portals and Tab Controls fail to "own" enclosed objects

               This is one of many acknowledged bugs that can be found in the Known Bug List thread here in the Report an Issue section of the forum.

               It can also be downloaded as a database file from:    https://www.dropbox.com/s/jt09b82i0xijbu3/FMP%20Bugs.zip

          • 2. Re: Field cannot be placed on portal, or only by chance
            TSGal

                 Rainer Schäferkordt:

                 Thank you for your post.

                 Make sure the top of the field is not touching the top of the portal.  Otherwise, it will only print once.  Click the field and press the down arrow key once or twice to move the top of the field below the top of the portal.  Then, the data will display for each record in the portal.

                 Let me know if you need additional clarification.

                 TSGal
                 FileMaker, Inc.

            • 3. Re: Field cannot be placed on portal, or only by chance
              AnalogonEnterprise

                   TSGal: Thanks for your reply. But as I stated, this does not help. Position of portal is 156, position of Field ist 157.

                   PhilModJunk: Thanks, placing the field first somewhere else and then in the portal again, solves the problem (at least this time).

                   This bug should be fixed immediately. It first appeared in FM12, and two years after its release and a full version later it is still there. FM13 provides a lot of tools for exact positioning etc., but in this case it's work of Sisyphus (originally the field was 'owned' by the portal, but as I corrected the position for 1 point, it was lost, and I had to start at the very beginning). 

              • 4. Re: Field cannot be placed on portal, or only by chance
                TSGal

                     Rainer Schäferkordt:

                     If you use the Inspector to position the field on the portal, it will not attach itself to the portal.  Using the arrow tools will attach itself.  In essence, if you have a field outside the portal, and just use the Inspector to position the field, it will position the field on the layout, but not in the portal.  Either drag the field into the portal first to attach it, or use the arrow keys to place the field in the portal.  Try the following:

                     1. Place a field within the portal.  Go to Browse to make sure it appears for each record.

                     2. Go to Layout Mode, select the field, note the position of the field in the Inspector.

                     3. Press the up arrow key five times (or more) to move the field out of the portal.  Go to Browse to see the value for the first related record only.

                     4. Go to Layout Mode, select the field, and enter the previous position for the Inspector.  The field looks like it is in the portal, but it is actually on top of the portal.  Go to Browse and see only one instance.

                     5. Go to Layout Mode, select the field, press the up arrow key once, and the down arrow key once, so it is back in the same position.  Go to Browse.  You will now see every instance appear in the portal.

                     TSGal
                     FileMaker, Inc.

                • 5. Re: Field cannot be placed on portal, or only by chance
                  Benjamin Fehr

                       I think, same behavior may occur with Popover-Windows and Slide-Elements

                  • 6. Re: Field cannot be placed on portal, or only by chance
                    TSGal

                         Benjamin Fehr:

                         Thank you for the clarification.  You are correct.  Popovers and Slide Elements work exactly the same way.  That is, Fields/Objects also need to be attached via dragging or using the arrow keys.

                         TSGal
                         FileMaker, Inc.

                    • 7. Re: Field cannot be placed on portal, or only by chance
                      philmodjunk

                           And please not that this can be a "useful bug". There are times when we don't want the object to be owned by the enclosing portal, pop over or slider. If/When this is fixed, we also need a new feature added that allows us to keep such an object from being enclosed for those cases when this is not desired. Otherwise, we are fixing one feature but breaking another.

                      • 8. Re: Field cannot be placed on portal, or only by chance
                        AnalogonEnterprise

                             TSGal: I'm sorry, but I can't confirm this. This may work sometimes, but isn't reliable. Until now, only the method PhilModJunk described works reproducible.

                             Is there any information when this bug will be fixed?

                        • 9. Re: Field cannot be placed on portal, or only by chance
                          Markus Schneider

                               If the object that was inside a portal row can't be moved back into that portal row (after moving it outside the portal row), there might be a problem with the file...

                               Placing objects into a portal row is sometimes somehow tricky - objects need a bit more space, one/two pixel more that the inspector shows for the portal row.. but moving an object should make it visible again.

                               Maybe there is a problem with the 'fractal' positioning (100.1234 pt instead of 100 pt) or with the border of an object - but that's a bug IMHO since FM12

                          • 10. Re: Field cannot be placed on portal, or only by chance
                            philmodjunk

                                 I will observe that this "feels more tricky" in version 13 than in 12.... I'm still considering a new bug report on a related issue, but have to be able to clearly describe and reproduce the behavior first...