3 Replies Latest reply on Jan 18, 2013 4:29 PM by philmodjunk

    Field Display Issue When Running Script

    swisskent

      Summary

      Field Display Issue When Running Script

      Product

      FileMaker Pro

      Version

      12.0v3 Advanced

      Operating system version

      Mac OS 10.8.2

      Description of the issue

      When a script navigates to a nested tab control object, it sometimes displays strange graphics over certain fields.  (See attached screenshot example.) 

      These fields have one conditional statement each that turns their font color to a light brown when the Status of the record is set to "Inactive".

      Steps to reproduce the problem

      Run a script that navigates to a nested tab control object containing conditional formatted fields  and then pauses (i.e. for user data entry).  The odd graphics will show up sometimes.

      Expected result

      Fields should be displayed with their data as expected.

      Actual result

      Sometimes, unexpected graphics are rendered where a field and its data should be shown.  (See attached screenshot.)

      Exact text of any error message(s) that appear

      n/a

      Configuration information

      n/a

      Workaround

      Go to another layout and then back to the affected layout; run the script again; the issue does not appear. 

      This seems to be some sort of layout refresh issue.  (BTW, I tried putting in a "Refresh Window" script step in the script, and it did not help.)

      Field_Display_Issue.png