3 Replies Latest reply on Aug 19, 2013 2:00 PM by disabled_ntaylor

    Fields not searchable in Instant Web Publishing

    AndyR

      Summary

      Fields not searchable in Instant Web Publishing

      Product

      FileMaker Pro

      Version

      12

      Operating system version

      Mac OS Mountain Lion

      Description of the issue

      We have a database in File Maker Pro 12 which we imported from Pro 7, in which certain fields are searchable (field type = text field). However, when this same database was recently published to the web via Instant Web Publishing those same fields are not searchable and instead appear as 'drop-downs' in which no text appear.

      Does anyone have ideas as to how to remedy this? Thank you!

        • 1. Re: Fields not searchable in Instant Web Publishing

          Andy R:

               Thank you for the post. 

                

               Are the text fields drop-downs? Has "Field entry" been disabled for Find mode? Regular text fields should not appear as drop-downs in Instant Web Publishing whether in Find mode or Browse mode.

                

               I created a simple .fp7 test file in FileMaker Pro 11 with a single text field, four records, and converted the file to .fmp12 using FileMaker Pro 12. Hosting the file with FileMaker's Instant Web Publishing allows me to type to perform a find on the field.

                

               If a new simple test file is created and converted, then can this behavior be replicated?

                

               TSFalcon

               FileMaker, Inc.

          • 2. Re: Fields not searchable in Instant Web Publishing
            AndyR

                 Thank you for your response, TSFalcon. How do I check to see whether "Field Entry" has been disabled? I well create and convert a test file once I have checked "Field Entry."

            • 3. Re: Fields not searchable in Instant Web Publishing

              Andy R:

                   Thank you for the reply.

                    

                   Open the file and Edit Layout > Select Field > Open Inspector > Data > Behavior > Field entry and check to see if the box for "Find Mode" is checked or unchecked. See attached screenshot below.

                    

                   TSFalcon

                   FileMaker, Inc.