2 Replies Latest reply on Sep 16, 2011 1:06 PM by J.C.LaBarrie

    file is not modifiable

    J.C.LaBarrie

      Summary

      file is not modifiable

      Product

      FileMaker Pro

      Version

      10

      Operating system version

      Windows XP

      Description of the issue

      The first error message I'm getting is saying "this action cannot be performed because this file is not modifiable."  When I log into windows as administrator and try to perform the same function it asks me for the password with an account name that I don't see in the account and privileges window.  So I enter an account and password that has full access and it doesn't recognize the account.  I've looked at other posts and I even unchecked "Use simple file sharing sharing (Recommended)" in windows xp folder options and nothing changed.

      Steps to reproduce the problem

      I'm trying to upload an image

      Expected result

      A window would pop up to browse for the image that you would want uploaded

      Actual result

      error message comes up twice

      Exact text of any error message(s) that appear

      "Action cannot be performed because this file is not modifiable" and "The account name and password you entered does not match those for any FileMaker account" when I log in as windows administrator and a full access privilege account in FileMaker Pro

      Configuration information

      We previously made changes to the server location which made all the fields not modifiable so then we changed privilege sets and everything worked fine except a button that uploaded images.

      fmp_problem_2.JPG

        • 1. Re: file is not modifiable
          philmodjunk

          "Action cannot be performed because this file is not modifiable"

          This error message indicates that a FileMaker file either has "read only" status specified or is in a directory for which the current user account (on the OS, not FileMaker ) does not permit modifying the file. Best bet is to check the security settings on the folder(s) that contain this file and also to check and see if you need to repair user account permissions. (Details depend on what OS you have.)

          Since you are being asked by FileMaker for an account you don't see in Manage | Accounts and Privileges, it's possible that you have an additional fileMaker file with different access accounts than the file you see open before you. If so, you may need to open Manage | External datasources and see what other files might be linked to this one and check their accounts and privileges to see if they might be the source of the open file dialog. I strongly suspect that's the case here as you clearly have some files already open when this dialog pops up.

          • 2. Re: file is not modifiable
            J.C.LaBarrie

             Thanks, that was fast.  I think you're pretty much right about everything.  I opened up Manage | External datasources and I see another database where I think the images were being saved.  When I tried to open that remote database of where the images are, I was able to see the images of previously uploaded images but I wasn't able to change anything (I didn't have the privilege).  I think I'm going to have wait to fix this because I dont have access to the server, but thanks again.