0 Replies Latest reply on Jun 21, 2012 7:43 PM by JohnDuncan

    FileMaker 12 Forgets Import Type when File not specified

    JohnDuncan

      Summary

      FileMaker 12 Forgets Import Type when File not specified

      Product

      FileMaker Pro

      Version

      12.0v1

      Operating system version

      Mac and Windows

      Description of the issue

      In FileMaker 11 you could set up an Import script step, select a file and specify that the file was to be imported as Comma Separated Values and it would work after unchecking the File checkbox.  This script has been working flawlessly for years.

      After converting to FileMaker 12 the import script step switched to importing as Tab Separated.  I went in and reset it to Comma Separated but after I unchecked the File option and went back in it was back to Tab Separated.

      Steps to reproduce the problem

      Use a Comma Separated file with a .txt suffix.
      Set up an import script to import that file into a table as comma separated.  Verify that it works.  Go back into the script and uncheck the "File" checkbox in the Import script step.  Run the script again and this time it will prompt of the file.  Note that the dialog box is pre-set to "Tab Separated"

      Expected result

      It should remember that it was Comma Separated

      Actual result

      It shows Tab Separated.  The user must manually change it to Comma Separated

      Exact text of any error message(s) that appear

      N/A

      Configuration information

      N/A

      Workaround

      Initially the script step was not offering the user the option of selecting the import format.  After modifying the script step in FM 12 it then added a pop-up menu to the dialog box when the user is prompted to import where they can select Comma Separated.