4 Replies Latest reply on Feb 20, 2013 1:30 AM by tomasd

    Filemaker client freeze when start search in long text field

    tomasd

      Summary

      Filemaker client freeze when start search in long text field

      Product

      FileMaker Pro

      Version

      11.0v3

      Operating system version

      Windows XP

      Description of the issue

      Filemaker database not responding, after user start search in the "Log" field. The field contains very long text in one or two records.

      Steps to reproduce the problem

      Start search in "Log" Field on "Release Procedure" layout. I can send the database.

      Expected result

      Filemaker client should not freeze.

      Actual result

      Filemaker client freeze.

      Exact text of any error message(s) that appear

      None

      Configuration information

      I have the database file (350 MB -> 9 MB zipped). You can reproduce it.

      Workaround

      Replace "Log" field in all records with empty text.

      Builds_Recovered.png

        • 1. Re: Filemaker client freeze when start search in long text field
          philmodjunk

               Very long text fields can produce very large indexes. What happens if you turn on indexing for this field?

               You might also try using recover to rebuild the field's indexes to see if that makes any difference.

          • 2. Re: Filemaker client freeze when start search in long text field
            tomasd

                 There was already set option: Automatically create indexes as needed. Even If I set index to none, the database has problem with very long text fields. With forbidden indexing I can search, but Filemaker client crashes when browsing these fields. I know it is special case, but i would expect, that Filemaker controls maximal limit on field and does not allow kill whole database with one long field.surprise
                  

            • 3. Re: Filemaker client freeze when start search in long text field
              philmodjunk
                   

                        There was already set option: Automatically create indexes as needed. Even If I set index to none, the database has problem with very long text fields.

                   Not what I was suggesting. I am suggesting that you enable "All" indexing on the field. There will be a significant delay while your table updates when you click OK to leave Manage | Database and your file will become larger in size, but your searches on this field may now go much quicker.

                   The above suggestion assumes that your file and the indexes for this field are not damaged.

                   Rebuilding the indexes can correct for that issue if a damaged index is the source of these delays.

              • 4. Re: Filemaker client freeze when start search in long text field
                tomasd

                     Thanks Phil,

                     indexes in Log field are propably corrupted, so the client freezes. There aren't short delays, the client stop responding. Sorry, but I can't wait and watch white screen (unresponsive client) and hope, that it will proceed after some very long time. 

                     I can repair the file, when I delete all data in Log field. I wonder, how easy can be the index broken. Why filemaker doesn't display some message, that index is corrupted?