AnsweredAssumed Answered

FileMaker enters a modal-like state on editing

Question asked by MikhailEdoshin on May 18, 2012
Latest reply on Jun 20, 2012 by MikhailEdoshin

Summary

FileMaker enters a modal-like state on editing

Product

FileMaker Pro

Version

v12 Advanced

Operating system version

Mac OS X 10.6

Description of the issue

I'm trying to set up a trigger-based system to edit a "matrix" report, i.e. like a cross-tab report, but editable. The gist of is is that as I load a record (OnRecordLoad) I fetch the column data for this record and populate a repeating field that represents the columns. Now I can enter the field and edit the values. After each edit (OnObjectExit) I grab the value and update the corresponding record in the related table (add, edit, or delete).

It all works flawlessly on v11, but on v12 I run into a problem: sometimes as I enter a cell FileMaker enters a modal-like state: it beeps on every keypress or mouse click, Close Window is disabled, Quit is disabled. All other commands are enabled though, so I can get out of it by switching to another mode (e.g. to Find mode and back). Although this helps, for some reason I have to select the command or press the hotkey *twice*, not once. I can also get out if I edit and save a script.

Another quirk is that if I evaluate the Get( ScriptName ) in the Data Viewer I see the name of my OnRecordLoad script. But if I open the debugger, there's no script. I've tried to write a script with the Halt Script command and run it via the Scripts menu, but it didn't help.

Steps to reproduce the problem

I have a sample file in my DropBox (http://dl.dropbox.com/u/9175169/MatrixTest.fmp12.zip). I wanted to attach it, but then realized I can only attach pictures.

As you open it, you'll be on the right layout. Try to click the matrix cells (the ones with numbers) and type new values, clear the existing ones, etc. Tab between fields or click haphazardly, or click somewhere else on the layout to commit. For me it usually takes about 20 clicks to get the error; once I managed to get it first time, it starts to happen much often.

Expected result

Edit goes smoothly; as I enter the field the data are always fully selected as it's specified in field options.

Actual result

As I enter the field the data may or may not be fully selected; after about 20 random edits/commits the application enters a modal-like state and starts beeping on keypresses or mouse clicks. The Quit and Close Window steps are disabled. If you evaluate "Get( ScriptName )" in Data Viewer you'll get a non-empty script name ("@Item: load usage"), but if you open Script Debugger, there won't be any script. You can get out of this state by switching to Find mode or Layout mode; note that you'll have to select the command twice to work or by editing and saving a script; if you do this, you'll get a message that this will stop the current script. Commit record, refresh window, revert record, running a script with Halt Script doesn't work.

Exact text of any error message(s) that appear

There's no error messages.

Configuration information

Nothing specific; vanilla FM Advanced v12, Mac OS X 10.6, no plug-ins.

Workaround

Switching to find mode helps to get out of it, but it's not something I would tell the customer to do.

Outcomes