4 Replies Latest reply on Jun 18, 2015 8:39 AM by TSGal

    FileMaker Go

    ericjlindholm

      Product

      FileMaker Go

      Version

      14.0.1

      Operating system version

      IOS 8.3

      Description of the issue

      Viewing PDF from container Opening Failure on FM GO
      Post:
      This is related to an old post.

      http://forums.filemaker.com/posts/101f965e5a

      it appears to be trying to access on port 80 which is open.

      I am using the most current FMserver 14 , pro advanced and FM go 14

      Steps to reproduce the problem

      Attempt to view a PDF from a container remotely

      Expected result

      View Container

      Actual result

      Failed to open.  Exact error in screen shot

      Exact text of any error message(s) that appear

      Failed to open "http://mystaticIP:80/Streaming/MainDB/33844402509131915D9334A3AE302041.pdf?SessionKey=33844402509131915D9334A3AE302041&RCType=EmbeddedRCFileProcessor"

      IMG_0678.PNG

        • 1. Re: FileMaker Go
          ericjlindholm

          any help would be much appreciated.  this worked before the upgrade to 14

           

          • 2. Re: FileMaker Go
            TSGal

            Eric Lindholm:

            Thank you for your posts.

            If the PDF is not stored remotely, does it work?  That is, temporarily create a new Container field (local storage), place the Container field on a new layout, format the field for Interactive content, and then embed the PDF file into the new Container field.  See if you are then able to use FileMaker Go and access the file.  This will let me know how to proceed.

            TSGal
            FileMaker, Inc.

            • 3. Re: FileMaker Go
              ericjlindholm

              To clarify my first post, the containers are all stored within the DB.  When I said that I was trying to view it remotely, I meant through the WAN and not my LAN.  When I attempt to access through the LAN, I get this message.

              Failed to open "http://SWP-iMac-Server.local:80/Streaming/MainDB/CFF22E157378C52870C5155B272D9B84.pdf?SessionKey=CFF22E157378C52870C5155B272D9B84&RCType=EmbeddedRCFileProcessor"

              I did the steps you asked for but to be sure I interpreted them correctly I will relist them.

              -Created new field "Attachments::test container" (internal storage)

              -Create New Layout "Attachment test(show records from table: attachments)

              -Add field "Attachements::test container" formatted for PDF

              -Add PDF doc from FMPro14 and from FMgo 14

              -Attempt to view PDF from FMgo14.  

              -Same error messages.

              • 4. Re: FileMaker Go
                TSGal

                Eric Lindholm:

                Thank you for the information.

                Let's first handle the error on the LAN...

                Move the database file to the iOS device to make sure the PDF file is viewable locally.  Launch FileMaker Go 14, open the database file, tap the Container field and view the PDF.  Does this work?  If not, then there could be something wrong with either the PDF file or the Container field.  If this works, make sure all necessary ports are open on the server.  For a complete list of ports, see Knowledge Base Article #14402:

                http://help.filemaker.com/app/answers/detail/a_id/14402

                Once the LAN issue is resolved, then try again over WAN.

                TSGal
                FileMaker, Inc.