AnsweredAssumed Answered

FileMaker Go Bug: Won't refresh screen properly

Question asked by scottworld on Jul 2, 2014
Latest reply on May 15, 2015 by scottworld


FileMaker Go Bug: Won't refresh screen properly


FileMaker Go



Operating system version

iOS 7.1.1

Description of the issue

There is a gigantic & reproducible screen refresh bug in FileMaker Go 13 that is making it EXTREMELY difficult for my clients to use FileMaker Go at a location that has 30 iPads deployed specifically for using FileMaker Go.

You can watch a video showing this major bug in action here:

- We have a layout in list view.
- The layout is based on the "Cool Gray Touch" theme.
- There is a global field in the header, where the user can type in a barcode # (or they can use a barcode scanner to type in a barcode # quickly).
- The global field uses the "OnObjectKeystroke" script trigger to detect the RETURN key. When the return key is pressed (or the barcode scanner sends the return key to FileMaker Go), all FileMaker does is create a new record with that barcode # in the new record.
- There is no trickery involved here!! The only thing that is happening is that a new record is being created, and then the rest of the fields you see are being populated via lookups. Then, the global field is erased and the cursor is put back into the global field at the top again. There is NOTHING FANCY GOING ON HERE! The only thing happening is that new records are being created, and data is being populated via lookups. This is beginner-level FileMaker here.

- This actually works just fine for the first 25 records or so.
- However, after the screen fills up with 25 records, that's when FileMaker Go can no longer refresh the screen properly anymore. It will stop refreshing the screen in batches of 6 or 7 records… we will just see blank lines as it is creating the new records. The new records are actually being successfully created by FileMaker and the lookups are being looked up successfully, but the screen is just blank. And then, suddenly, FileMaker Go will catch up and refresh everything again.
- This bug happens on the latest generation of iPad Airs and the latest generation of iPad Minis.
- We have tried adding a "pause" script step to the script to have it pause for a few seconds in between creating each record, but the bug still happens.
- We have tried adding a "refresh window" script step after each new record creation, but the bug STILL happens!

Can you please fix ASAP?? It is driving my clients crazy, after they just spent all this money on iPads!! And they are getting upset with me, because I was the one who told them that this would work for their needs!!

Thank you!!