10 Replies Latest reply on Apr 19, 2016 2:17 PM by Borgo1971

    Filemaker odbc driver 12v3 doesn't return data

    MelanieCotton

      Summary

      Filemaker odbc driver 12v3 doesn't return data

      Product

      FileMaker Server

      Version

      12

      Operating system version

      Windows 2008 on server and Windows 7 or mac osx on client

      Description of the issue

      Hi, I'm using LibreOffice Base to create queries that retrieves data in Filemaker via the ODBC driver 12v3. Since version 12, it seems like the connection is well done but the data cannot be retrieved, I get this error message: "The data content could not be loaded. The execution of the query doesn't return a valid result set."

      Thanks

      Steps to reproduce the problem

      - Install FM server 12v3
      - On client side, install latest version of LibreOffice and FileMaker odbc driver 12v3.
      - In LibreOffice, create a simple query that retrieves some information in a database and try to run it.

      Expected result

      See the data returned by the query.

      Actual result

      The connection is well done but the data cannot be displayed.

      Exact text of any error message(s) that appear

      The data content could not be loaded. The execution of the query doesn't return a valid result set.

      Configuration information

      you need:
      - FileMaker server 12v3
      - A DSN that points to a database on your server with Filemaker odbc driver 12v3
      - LibreOffice latest version (I use 3.5)
      - Configure the connection to the database via LibreOffice:
      Edit -> Database -> Connection Type
      Database Type = ODBC
      Name of the ODBC data source on your system = the dsn previously created
      User authentication = the user name and password used to access your FileMaker database
      Character set = System

      Workaround

      There is no workaround for this issue.

      error.png

        • 1. Re: Filemaker odbc driver 12v3 doesn't return data
          ErikToh

               I am experiencing this exact same problem as well. To add to what Melanie has stated above, I am able to view the table names, but I'm unable to retrieve any data. I suspect it has to do with the new version because FMPA 11 was able to serve as an ODBC data source without problems.

               My setup:

               LibreOffice for MacVersion 3.6.4.3 (Build ID: 2ef5aff)

               FMPA 12v03 (10-09-2012)

               FileMaker ODBC driver v12.3.103

               Mac OS X v10.8.2 Build 12C3006

          • 2. Re: Filemaker odbc driver 12v3 doesn't return data
            Jean-AlexisMontignies

                 Same problem here:

                 FileMaker Pro 12.0v4

                 FileMaker ODBC driver 12.3.103

                 ODBC Manager 1.0.11

                 MacOS X 10.7.5

                 LibreOffice 4.0.3.3  or  ODBC query tool 0.5.0 -> it really looks like a filemaker issue and it's blocking.

            • 3. Re: Filemaker odbc driver 12v3 doesn't return data
              Borgo1971

              And same problem here:

              FileMaker Pro 12.0.5 (32bit) and 14.0.5 (64bit)

              FileMaker ODBC driver 12.5.106 and 14.0.10

              ODBC Manager 1.0.15

              MacOS X 10.9.5

              LibreOffice 5.1.2 / NeoOffice 2015.5 / OpenOffice 4.1.2 (all 64bit)

               

              Nobody has come at the head of the problem?

              The same solution was working fine in FileMaker Pro 11, but now I must update.

              • 4. Re: Filemaker odbc driver 12v3 doesn't return data
                TSGal

                Borgo1971:

                 

                Thank you for your post.

                 

                I am unfamiliar with LibreOffice, NeoOffice and OpenOffice.

                 

                What is the query being sent to FileMaker?  There was a file format change between FileMaker Pro 11 and FileMaker Pro 12.

                 

                What is the primary key field specified in LibreOffice, NeoOffice and OpenOffice?  What primary FileMaker table::field is being matched to this key field in LibreOffice/NeoOffice/OpenOffice?

                 

                TSGal

                FileMaker, Inc.

                • 5. Re: Filemaker odbc driver 12v3 doesn't return data
                  Borgo1971

                  Sorry, I've not the skill to answer your questions. I try to explain the problem at best I can. But LibreOffice and OpenOffice are free software, so I think you can download and try to learn more about the issue.

                  I normally use Marge Prints from NeoOffice (but as I saw, all xOffice have the same behavior), taking data from FileMaker DB open on localhost. To do this, I made some open document DB file that are simple links to FileMaker through ODBC... mostly I get addresses and some personal data from client DB, but from NeoOffice I can see all tables in the linked files (accessing the data according FileMaker security setup). This until now I used FileMaker 11 and it's own ODBC driver.

                  Now I must move to .fm12, because may firm is upgrading their server with FileMaker Server 12, but the problem is not related to server version of FileMaker... my solution is locally open and even I need some link to the firm DB, I temporally removed all link to the server because it's unavailable. This is a screenshot of NeoOffice displaying data from FMP11 and ODBC11 (alias for FM11 ODBC driver) running on my Mac:

                  Schermata 2016-04-15 alle 08.10.51.png

                  With FMPA14 and ODBC11, with which I can see tables and fields name, but not the data inside:

                  Schermata 2016-04-15 alle 08.42.45.png

                  And this are the error massage I get using any other ODBC driver between 12 and 14, in combination with any FileMaker 11, 12 or 14:

                  Schermata 2016-04-14 alle 10.09.07.png

                  Schermata 2016-04-15 alle 07.42.50.png

                  Schermata 2016-04-15 alle 07.42.54.png

                  I can say that I get the same errors with FileMaker 11 and ODBC 11 if I try to access unshared tables. In the screenshot above, only "Modul-PRA" and "Modul-REP" are shared fmxdbc tables:

                  Schermata 2016-04-15 alle 18.51.48.png

                  Hope this helps.

                  Regards,

                  Adriano.

                  • 6. Re: Filemaker odbc driver 12v3 doesn't return data
                    TSGal

                    Borgo1971:

                     

                    Thank you for the additional information.

                     

                    First, there was a major file format change beginning with FileMaker Pro 12, so what worked in FileMaker Pro 11 (older file format) may not necessarily work again with FileMaker Pro 12 (and 13 and 14).  The ODBC driver from FileMaker Pro 11 will definitely not work with FileMaker Pro 12/13/14 database files.

                     

                    The ODBC manager may still be linked to the old FileMaker 11 ODBC driver, so create a new ODBC account for FileMaker 14 that links to the new FileMaker 14 ODBC driver.

                     

                    TSGal

                    FileMaker, Inc.

                    • 7. Re: Filemaker odbc driver 12v3 doesn't return data
                      Borgo1971

                      Even the new ODBC driver replaces the old one, I tried to remove all of existing parts of the driver (I removed /Library/ODBC and ~/Library/ODBC), open document format database links, and recreate entry setup, but nothing helped.

                      After all I reinstalled ODBC 11 driver and FileMaker 11 let me access the data using the configuration made with FileMaker 14, so I guess it is not useful.

                      The fact that I can see the tables inside the databases opened in FM12-14 (see third screenshot) is another indication that ODBC links correctly NeoOffice to FileMaker... after all, I guess that there is something wrong inside filemaker or it's new file format, that let NeoOffice/LibreOffice/OpenOffice not access the data. And that's a great problem becouse I can't do anything to avoid it.

                      • 8. Re: Filemaker odbc driver 12v3 doesn't return data
                        Borgo1971

                        Maybe you or someone else can help me to configure JDBC, as last workaround? I installed JDBC coping fmjdbc.jar in /Library/Java/Extensions/, launched FileMaker and saw fmxdbc_listener in Activity monitor. After that I tried to create a new OpenOffice DB to link FileMaker (same way I did with ODBC on FM11). NeoOffice ask me the datasource url and JDBC class... reading FileMaker ODBC and JDBC Guide, I come on this:

                        Schermata 2016-04-19 alle 17.05.27.png

                        but something seems to be wrong. Hope someone can help me on this...

                        • 9. Re: Filemaker odbc driver 12v3 doesn't return data
                          TSGal

                          Borgo1971:

                           

                          Change the IP Address to either 127.0.0.1 or localhost.  Does this then work?

                           

                          Also, make sure ODBC/JDBC Sharing is turned On, and access to the database file is set to All Users or Specify users by privilege set.

                           

                          TSGal

                          FileMaker, Inc.

                          • 10. Re: Filemaker odbc driver 12v3 doesn't return data
                            Borgo1971

                            Even IP address was my fault, the correction does not resolve the problem. Access is turned ON... the file setup is the same I have in FM11 version. I'm trying again with this converted file, but the last day I tried with a scratch new DB made in FMP12 too, with no results.

                            But at last I found the way to access FileMaker data with LibreOffice 5.1.2 (seems not to work with NeoOffice)! I installed JDK 8 update 77, selected the Java virtual Machin in LibO, corrected the IP and the Class driver... capital letter are fundamental: com.filemaker.jdbc.Driver! And voilà: Schermata 2016-04-19 alle 23.14.23.png

                            So for now I'm happy to have found a workaround, but I hope there will be a working ODBC solution in the future.

                            Regards,

                            Adriano.