7 Replies Latest reply on Jul 31, 2009 7:16 AM by TSGal

    FileMaker Pro Advanced 10 Help gone

    CamelCase

      Summary

      FileMaker Pro Advanced 10 Help gone

      Description of the issue

      I opened my FMPA10, and discovered that help no longer is working. A Help browser window opens but just shows a blank "Untitled" window. The help files are not gone; I can still acces them through a browser at file:///Applications/FileMaker%20Pro%2010%20Advanced/FileMaker%20Pro%20Advanced.app/Contents/Resources/English.lproj/FileMaker%20Pro%20Help/index.html Help used to work until recently but I don't remember for sure if I've used it since I installed the FileMaker Pro Advanced 10.0v updater. I'm on Mac OS X 10.5.6; FileMaker Pro Advanced 10.0v.  

        • 1. Re: FileMaker Pro Advanced 10 Help gone
          TSGal

          DavidWikstrom:

           

          Thank you for your post.

           

          I am running FileMaker Pro 10 Advanced on Mac OS X 10.5.7, the update ran successfully, and I can access Help.  I know that doesn't help you, but just wanted to let you know that it should work as you expect.

           

          It sounds like Help worked prior to the update.  Was your copy of FileMaker Pro installed on a different volume prior to the update?  If you can remember, were there any other applications running when the updater was running?  Did you notice anything else out of the ordinary, even if minute, after the updater ran?

           

          This is a longshot, but remove the preference file.  When FileMaker launches, it reads information from the preference file.  If the file is not there, a new one is created.  Therefore, remove the file:

           

          Home -> Library -> Preferences -> com.filemaker.pro.advanced.plist

           

          Relaunch FileMaker Pro and try to access Help.

           

          If still unsuccessful, you may have to uninstall and reinstall FileMaker Pro 10 Advanced and run the updater again.

           

          Please keep me updated with any progress.

           

          TSGal

          FileMaker, Inc. 

          • 2. Re: FileMaker Pro Advanced 10 Help gone
            CamelCase
              

            Hi TSGal,

             

            Thanks for your reply.

             

            Deleting the preferences file actually didn't help.

             

            I know I can reinstall, but my problem isn't really that it's not working (accessing help via a browser is so much  faster anyway that I normally use that option, and it also allows me to toggle between help in different languages).

            My concern is rather how on earth something like this can happen at all - I'm worrying that it could happen to one of my clients.

            It certainly doesn't give a very professional impression - you don't even get an error message. Since the help files are there, but the reference to them somehow must be broken inside the app (or how does FileMaker Pro know where the help files are?), FileMaker Pro should be able to identify and fix the problem automatically when you launch the app.

             

            As I mentioned, I'm not at all sure that this is related to the latest update; I just know that this happened fairly recently.

            • 3. Re: FileMaker Pro Advanced 10 Help gone
              TSGal

              DavidWikstrom:

               

              Thanks for trying the preferences file.  Like I originally said, it was a longshot. 

               

              FileMaker Pro (Advanced) looks for the Help file in the application bundle (as you have pointed out) on the Mac version, so I'm surprised this is not working for you.  Not knowing with certainty where that reference is stored, as a possibility, I thought it might be stored in the preferences file, so that is why I suggested removing it.

               

              The only thing I did notice is that the Help does take some time to load on my iMac (2.4 GHz).  After launching FileMaker Pro 10 Advanced and accessing Help, I searched for "FilePath", and that took several seconds.  When I selected "Show All Results", an empty box appeared and after ten seconds, the information finally displayed.

               

              I also don't know if this is related to the update, but I definitely want to pursue that avenue in case there is a problem.

               

              TSGal

              FileMaker, Inc. 

              • 4. Re: FileMaker Pro Advanced 10 Help gone
                CamelCase
                  

                Some progress but no real solution/explanation:

                 

                Just reinstalling FileMaker Pro Advanced 10 did not fix the problem.

                 

                After manually deleting the folder and then re-installing FileMaker Pro Advanced 10 (checking all languages available), I could access help normally. I thought there was an uninstall option? Or is that just for FMS?

                 

                I then proceeeded to install the updater, selecting all languages - interestingly, more languages than were available in my original installer file (fmpa_10.0.1.89).

                 

                After installing the updater, launching help in FMPA10 no longer shows me the strange "Untitled" window, but simply the Mac help.

                 

                I then once more manually deleted FileMaker Pro Advanced 10 and also FileMaker Pro 10 (which I barely ever use - just noticed help wasn't working there either).

                 

                Next, another reinstall of FMPA10, this time just checking the languages I may need (English, French, German, Italian, Swedish - not Japanese). When I lauch the help, I can actually see the window starting on the "Untitled" page, then going to the general Mac Help, and finally ending up on the FileMaker Pro Help (at least the first time; second time I was only able to see
                "Untitled" and "FileMaker Pro").

                 

                I then gave the updater another go now only checking the languages above (not sure why not all languages are available in my original installer - I would most certainly need Spanish and Dutch wouldn't be bad.

                The result is once again that I only get the general Mac Help and can only access the FileMaker Pro help from a browser.

                 

                So it seems this might be related to the updater after all; I know there is a bug when updating in French, so maybe there's some kind of combined situation where the updater doesn't handle multi-language insalls/updates properly  (http://thefmkb.com/7327).

                 

                • 5. Re: FileMaker Pro Advanced 10 Help gone
                  CamelCase
                    

                  More fun:

                   

                  I re-installed FileMaker Pro (not advanced), with the same language options as for Advanced; help worked perfectly. I then installed the updater (same languages once again), and I get the same bug as what has been reported for French (menu says FileMaker Pro Advanced even though I'm running FileMaker Pro). French is one of the available languages, but I am running the program in English.

                  • 6. Re: FileMaker Pro Advanced 10 Help gone
                    CamelCase
                       I've now had at least one other person confirm the help issue - I believe this user also has at least French and maybe other languages installed.
                    • 7. Re: FileMaker Pro Advanced 10 Help gone
                      TSGal

                      DavidWikstrom:

                       

                      Thanks for taking the time to narrow this down.  I'm on an English only version, so that is why I wasn't able to initially duplicate the problem.

                       

                      I have forwarded the information to our Development and Software Quality Assurance (Testing) departments for review and confirmation, and if any other information becomes available, I'll let you know.

                       

                      TSGal

                      FileMaker, Inc.