4 Replies Latest reply on Nov 2, 2009 3:08 AM by alanj49_1

    FileMaker Pro Advanced Updater v3 ends up uninstalling FMP10A v1

    bush46

      Summary

      FileMaker Pro Advanced Updater v3 ends up uninstalling FMP10A v1

      Description of the issue

      I am using Windows XP SP3. I installed FMP10 Advanced v1 from original CD. Then downloaded fmpa_updater_10.0.3.303.exe and 'updated' my v1 to v3 or so I thought. The updater went through all steps as if installing new files and removing old files but in the end it 'apparently' uninstalled and removed the previous installation! I used the CD again and asked it to 'remove' the existing application which it appeared to do. Then I installed V1 again and tried updating it and again the same thing happened with a strange ending. Sorry did not grab screen but I will if it happens again. This is baffling! In the FM on line notes I found that in case of problem I should first uninstall the prvious version using Windows uninstaller which I have now done (It seemed to still see FMP10A in the list). I am now first doing a disk cleanup and will do a defrag and also a disk error check on restart. Then I will try again and report back.

        • 1. Re: FileMaker Pro Advanced Updater v3 ends up uninstalling FMP10A v1
          bush46
            

          I return to report. After a Windows-based FMP10A uninstall, disk cleanup, defrag and disk error check on restart, I successfully installed the FMP10A from original CD and checked it by opening a database file. I did not register it because the on-line registration process asks for a number that is neither on the box nor anywhere in the accompanied flyers, booklet etc.

          Next I launched the V3 updater. It went through all the stages again, Status progress bar showing Copying new files > Validating install, Removing files, Removing Backup files and finally the message that it had 'successfully installed the FMP10A'. It ended with a Microsoft Installer window showing some text about silent install, etc with an OK button and in front another window 'Microsoft Windows Installer' with a message 'Configuring FileMaker Pro Advanced' that was doing nothing for a very long time. In the meanwhile I checked the folder where it originally installed C:\Program Files\FileMaker\FileMaker Pro 10 Advanced and there was no such folder. The shortcut icon created on quick launch bar can't find the application. A Windows search can't find it anywhere on the computer.

          I must add that my home computer had FMPA v9.5 that I had deactivated and unstalled earlier. This FMP10A is the second copy I am installing at home. I installed the first copy at the office (on Vista) and it updated without problems but not yet registered because of the above-mentioned number problem.

          Even if there was any problem because of non-registration/activation I would expect a more intelligent response from the updater.

           

          The Windows Add or Remove Programs listed FMP10A v3 as 'installed' with Size 521MB. I clicked on Change button and had options Modify, Repair or Remove. I clicked on Repair button and it asked for Customer Information again with Licence Key. I inserted the CD although it had not asked for it. I entered the information again exactly as at the office (The licence allowes one copy at home). It started copying files (but not from the CD! God knows where it was copying from!) and guess what? The FMP10A folder is back again in its right place with all its contents and the application is version 10.0.3.303.

          AND it is working. I managed to get it registered too as it automatically came up with a number that I suppose belonged to my previous 9.5 install (?).

          Could someone please explain what was happening?

          • 2. Re: FileMaker Pro Advanced Updater v3 ends up uninstalling FMP10A v1
            alanj49_1
               I am getting exactly the same thing with Windows 7, I can install FMP 10 and FMP 10 Adv but whenever I install the 10.0.3.303 upgrade FMP 10 Adv uninstalls itself at the end
            • 3. Re: FileMaker Pro Advanced Updater v3 ends up uninstalling FMP10A v1
              bush46
                 I don't have Windows 7 but if you can get to the Windows Programs Install/Uninstall window, can you still see FMP10A listed? If so, try repairing it and see what happens. It worked for me.
              • 4. Re: FileMaker Pro Advanced Updater v3 ends up uninstalling FMP10A v1
                alanj49_1
                  

                I managed to achieve that after about the 5th or 6th attempt, seems to be working now. I don't know why this has all started as I have it installed under Windows 7 on my laptop