5 Replies Latest reply on Mar 21, 2014 8:13 AM by TSGal

    FileMaker Server Advanced 11 Installer Crashes

    LucyGilbert

      Summary

      FileMaker Server Advanced 11 Installer Crashes

      Product

      FileMaker Server

      Version

      11

      Operating system version

      Mac OS X 10.6.8

      Description of the issue

      Installer runs most of the way through, then says that it is installing the "Admin Console."  But the console never launches.  Attempting to start the server stalls, i.e. the fmserver_helperd takes uses all available CPU and never launches the server.

      Steps to reproduce the problem

      Run the installer, continue through to the end.

      Expected result

      Admin console is installed

      Actual result

      Installer crashes and not all tools are installed.

      Exact text of any error message(s) that appear

      Process:         FileMaker Server 11 [48928]
      Path:            /Volumes/FileMaker Server 11/FileMaker Server 11.app/Contents/MacOS/FileMaker Server 11
      Identifier:      com.MindVision.VISEX
      Version:         3.3 (3.3)
      Code Type:       X86 (Native)
      Parent Process:  launchd [163]

      Date/Time:       2014-03-13 12:00:44.513 -0400
      OS Version:      Mac OS X 10.6.8 (10K549)
      Report Version:  6

      Exception Type:  EXC_BAD_ACCESS (SIGBUS)
      Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
      Crashed Thread:  0  Dispatch queue: com.apple.main-thread

      Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
      0   com.filemaker.personalizeapp       0x169dc0bb XCodMain + 248
      1   com.MindVision.VISEX               0x00063c61 CheckCodeResource + 895
      2   com.MindVision.VISEX               0x0000e160 MainLoop + 1056
      3   com.MindVision.VISEX               0x0004d8f2 ProgressAbort + 32
      4   com.MindVision.VISEX               0x0001ac19 MyProgressAbort + 63
      5   com.MindVision.VISEX               0x0001ac70 GiveProgressTime + 31
      6   com.MindVision.VISEX               0x0004f1b3 DeleteFile + 124
      7   com.MindVision.VISEX               0x0000ea75 HaveLaunchFile + 306
      8   com.MindVision.VISEX               0x0000ef3c DoAuthorization + 512
      9   com.MindVision.VISEX               0x0000f7c0 CheckMinInstall + 81
      10  com.MindVision.VISEX               0x00016af4 InitGlobals + 2922
      11  com.MindVision.VISEX               0x0001808c main + 81
      12  com.MindVision.VISEX               0x00006ac6 _start + 216
      13  com.MindVision.VISEX               0x000069ed start + 41

        • 1. Re: FileMaker Server Advanced 11 Installer Crashes
          TSGal

               Lucy Gilbert:

               Thank you for your post.

               The likely scenario is that you have Java 1.6.0_51 or later installed on your Mac.  Please see Knowledge Base Article #11958 for more information.:

          http://help.filemaker.com/app/answers/detail/a_id/11958

               Let me know if this still does not fix the issue.

               TSGal
               FileMaker, Inc.

          • 2. Re: FileMaker Server Advanced 11 Installer Crashes
            LucyGilbert

                 Thanks for your help so far.

                 Now the admin console launches, but there is no server for it to communicate with.  Attempting to start the server with either

                 fmserver start server

                 or

                 fmserver restart adminserver

                 outputs:

                  

                 Error: 10007
                  
            • 3. Re: FileMaker Server Advanced 11 Installer Crashes
              TSGal

                   Lucy Gilbert:

                   If you can get Admin Console launched, then choose Server menu, and select Open Test Page, or click the Open Test Page icon in the toolbar.  Or, type into a web browser:    http://<IP Address of Server>:16000/test     ... as this lets you use the Technology Tests page without logging into Admin Console.

                   Run through all relevant tests to determine what isn't working properly.

                   TSGal
                   FileMaker, Inc.

              • 4. Re: FileMaker Server Advanced 11 Installer Crashes
                LucyGilbert

                     When I run the Admin Console, it shows a dialog box with "The Database Server is not available.  To edit server deployment, please start the Database Server first."

                     When I run the first test ("Test FileMaker Pro"), I get a dialog box that says "Unable to start the database server.  Please contact your system administrator for assistance."

                      

                     The rest of the tests, in the Web Publishing section, are grayed out.

                      

                • 5. Re: FileMaker Server Advanced 11 Installer Crashes
                  TSGal

                       Lucy Gilbert:

                       Thank you for the information.

                       There are a number of factors that could be causing this.  The best action would be to call our Technical Support department.  If you are in North America, call toll-free 800-325-2747.  If outside of North America, contact the FileMaker office nearest you.  Technical Support can run down an expanded checklist, and depending on the answers, know how to proceed.

                       TSGal
                       FileMaker, Inc.