AnsweredAssumed Answered

FileMaker unable to match a color using color chooser

Question asked by datadoug on Mar 13, 2010
Latest reply on Mar 27, 2010 by datadoug

Summary

FileMaker unable to match a color using color chooser

Description of the issue

FileMaker Product(s) involvedFilemaker 10, 10 Adv, 11, 11 AdvOperating System(s) involvedMacOS 10.6.2 (Snow Leopard)Detailed description of the issueWhen trying to define the color of a layout object, if you select "other color..." then select the magnifying glass to select a screen color to match, the resulting color is darker than the selected color. This makes it difficult to match the color of existing layout objects. It appears that when the "Other color..." window is open it defaults to Generic RGB values, however, when you use the magnifying glass to select a screen color, it switches to Device RGB values (which are different), but uses the Generic RGB values as Device RGB values, thus selecting a darker version of the color. See work around below. This is probably due to Snow Leopard's change in gamma. Exact steps to reproduce the issue• Enter layout mode• Draw a box on the layout• Change it's color to a muted mid-tone color (this shows the effect more than a really saturated color)• Draw a new box• Now change its color by going to "other color..." and selecting the magnifying glass and moving it over the first box and selecting it as the source color• The resulting color is darker than the color you're trying to match Expected ResultIt is expected that the color result matches the source.Actual ResultThe color result is darker than the source.This is probably due to the fact that Snow Leopard uses a different gamma setting than in previous OS versions.It appears FMI has not yet addressed this.Exact text of any error message(s) that appearedNone.Any additional configuration information/troubleshooting that is relevant to the issueOther applications that use the color chooser that I have tested do not exhibit this behavior.Workarounds• Select a layout object in which you want to apply a color change• Select the fill color and choose "other color..."• Select the "Color Sliders" tab at the top of the color palette window (it's the second form the left)• Select "RGB Sliders" from the drop down list• If you click the small color box drop down list to the left of the "RGB Sliders" field, it probably says "Generic RGB". Don't change this yet.• Click the magnifying glass and select a source color form the screen (you'll notice that the color in the selection box is darker)• Write down the RGB values shown• Click the small color box drop down list to the left of the "RGB Sliders" field. It probably now says "Device RGB". Now select "Generic RGB"(when you select Generic RGB you'll notice the values change)• With Generic RGB selected, enter the RGB values that you previously wrote down• You should now have the correct color. Changing the RGB type prior to selecting a color seems to have no effect. It always switches to "Device RGB" after you have made a color selection, but uses the Generic RGB values. 

Outcomes