11 Replies Latest reply on Aug 19, 2011 12:58 PM by philmodjunk

    Find range using ...

    mfujimoto

      Summary

      Find range using ...

      Product

      FileMaker Pro

      Version

      11

      Operating system version

      Windows

      Description of the issue

      Have a text field (name field)-doing a find.  type in A...Z ; names that start with Z do not come up. Anyone else have this happen?  I thought using ... contains both ends of the range I'm trying to find?

      Steps to reproduce the problem

      Name field; find mode, type in "A...Z" into the name field

      Expected result

      expect to find the names that contain Z especially ones that start with Z

      Actual result

      eliminated the Z names from the find

      Exact text of any error message(s) that appear

      none

        • 1. Re: Find range using ...
          philmodjunk

          Can you confirm that this field is of type text and not number?

          Using FileMaker 11 on my windows XP system, if I enter into Find mode and type A...Z in a name field, I find all names starting with A through Z, and if I create a record where 111 is in the name field, that record is not found.

          • 2. Re: Find range using ...
            mfujimoto

            Yes, this field is a text field.  I added ZZ as a name and Z as a name.  When I find using "A...Z" it find the Z but not the ZZ name.

            • 3. Re: Find range using ...
              philmodjunk

              I have the following names in my table:

              Smith
              Higgins
              Flintstone
              ZZipster
              111

              When I enter Find mode and enter A...Z (no quotes)

              I get all the names shown above except 111

              • 4. Re: Find range using ...
                mfujimoto

                Okay...I started a brand new dataset table.  Only variable is a name field as a text field.  I have the following in my names in my dataset:

                Andrew

                Z

                zebra

                Sue

                Tania

                Marcus

                I do a find on a...z (no quotes) and it finds 5 out of the 6 (it eliminates zebra).   ??????

                • 5. Re: Find range using ...
                  philmodjunk

                  Are you doing this manually or in a script?

                  What version of windows? (Just trying to nail down any possible differences here.)

                  I also tried both lower and upper case letters and both work the same.

                  • 6. Re: Find range using ...
                    mfujimoto

                    I am doing this manually (no script) 

                    I am doing this in Windows 7 (64 bit); Filemaker 11.0v3 1-25-11. 

                    I had my IT guy try it on a Windows 7 (32 bit) and the same thing happens.  We added the names:

                    Z

                    Zoe

                    Zachary

                    Zeus

                    Marcus

                    Andy

                    We tried both lower and upper case letter (A...Z and a...z) finds and the results are the same.  Just finds the name Z, Marcus, Andy.  We also tried (A..Z and a..z) and still it only finds those 3 names. 

                    • 7. Re: Find range using ...
                      philmodjunk

                      The only difference here, between you and me that I can see is that I am using Windows XP where you are using 7. If you have an older XP machine that you can play with, it might be interesting to test and see if you get the same results I do on that machine--and this would strongly suggest that there is some difference inherent between Windows 7 and other platforms that needs to be investigated.

                      What results do you get if you use: a*...z* ?

                      I get the same results as just using the letters, but maybe it's a work around you can use in 7 to get the needed results.

                      • 8. Re: Find range using ...
                        mfujimoto

                        The a*...z* seems to work.  I will try to find Windows XP loaded with Filemaker this week to try it.  I'll let you know.  Thanks.

                        • 9. Re: Find range using ...
                          philmodjunk

                          Let me know what you find out. I can drop a line to the tech folks at FileMaker asking them to look at this thread if they don't do that on their own.

                          • 10. Re: Find range using ...
                            TSGal

                            mfujimoto:

                            Thank you for your post.

                            Remember that a range takes you from the first value to the last value, inclusive.  With a range set from a..z, you are finding all values between "a" and "z", inclusive.  Anything greater than "z" will not be found, and that would include "zebra" or anything else that begins with the letter "z".  If you want all entries that begin with the letter z, then you would need to set the range as:   a..z*    or   a..zzzz

                            PhilModJunk - I'm unable to replicate your findings on Windows XP.  Is it possible you have other words in the text field?

                            TSGal
                            FileMaker, Inc.

                            • 11. Re: Find range using ...
                              philmodjunk

                              That' explains it. I forgot that detail and was searching a name field that contained first and last names. I thought your explanation was why this was the case, but when my "quickie test" mislead me, I posted the results as I did... Embarassed