1 Reply Latest reply on Jun 23, 2009 2:08 PM by TSGal

    Find/Replace script steps no longer working as expected with FM10

    1802562120

      Summary

      Find/Replace script steps no longer working as expected with FM10

      Description of the issue

      Hi,I have been a little stumped by this apparent change of behaviour in FM10 when usingthe Find/Replace function. (My old FM9 scripts no longer work!). I hunted around theFM & TechNet website with this a few weeks back but didn't see anything on it. I use the Find/Replace function in preference to 'Set Field...' for mail merge functionsas it preserves text formatting and can more easily do exact or whole word substitutions. As you may know a field must be active in order to use Find/Replace function within the 'Current Field'.It appears that when FM10 can't find the 'Find' text ie: {My_ Merge_Field} it does somesort of exit field or commit which means there is no longer an active field. This causesa 905 error "No active field selected..". The workaround is to add a Goto Field step aftereach Find/Replace step - a bit dull if you have 15 or so merge fields!I have an example file I can send if this needs further clarification. Thanks Nick 

        • 1. Re: Find/Replace script steps no longer working as expected with FM10
          TSGal

          Spoton:

           

          Thank you for your post, and I apologize for the late reply.

           

          The "Perform Find/Replace" script step gives the user the ability to specify searching across all records or the current record, as well as across all fields or just the current field.  If you select the current field, you must ensure your cursor is active in that field.  This can usually be accomplished with a "Go to Field" step just preceding the "Perform Find/Replace" script step.

           

          This allows greater control as you can specify the exact field contents you want replaced.

           

          TSGal

          FileMaker, Inc.