AnsweredAssumed Answered

Finds on unstored calcs stop working in hosted file

Question asked by Jeremiah_Hammond on Jun 21, 2014
Latest reply on Sep 27, 2016 by TSGal

Summary

Finds on unstored calcs stop working in hosted file

Product

FileMaker Server

Version

FileMaker Server 13.0.2.295, FileMaker Pro 13.0.3.231

Operating system version

Windows Server 2008 R2 Standard SP1 64-Bit

Description of the issue

I work with a couple of hosted FileMaker solutions that, once every 2-3 months, finds on unstored calcs will stop working. Only way to get them working again is to restart the database server. Each solution is on their own FileMaker Server, and both are hosted on Windows Server 2008 R2.

FileMaker Server behaves like there's some sort of switch that gets flipped and after that, unstored calc finds stop working. It's not like they work sometimes and don't work at other times: they always fail once the problem starts happening. Closing the hosted file and opening it back up doesn't fix the problem; only restarting the database server does.

This is an alarming issue. Finds are a fundamental part of FileMaker and should always return accurate results. If you have a mission-critical system that relies on finds on unstored calcs, this bug could cause all sorts of damage depending on what the system is doing with the results. In my case, one of the above solutions is audited each night via a server-side schedule. This schedule does finds on unstored calcs in a product table and emails out any discrepancies. When unstored calc finds stop working, every record in the product table fails the audit and so all product IDs are included in the email, a telltale sign the server isn't resolving unstored calc finds correctly.

I've been running into the problem since FileMaker Server 10, but because of how infrequent it occurs, and because I can't reproduce the problem, I haven't bothered reporting it. I still can't reproduce the problem, but perhaps your development team has a hunch what's going on.

I have a video demonstrating the problem. Please message me and I'll send you a link.

I'm also willing to do a screen share when the problem happens again. I can't show you anything right now because I had to fix the solution in the video, but the next time it happens (trust me, it will!) I'd be more than happy to reach out to someone on your end so they can poke around the server.

Steps to reproduce the problem

Wish I could!

Expected result

Finds on unstored calcs return correct results

Actual result

Finds return incorrect results, sometimes random results, sometimes no results

Exact text of any error message(s) that appear

Not applicable

Configuration information

I haven't seen this happen when FileMaker Server is on a Mac, but that doesn't mean much. The majority of FM servers I've dealt with in the past were on Windows.

Taking down the hosted file, opening it up locally and repeating the find will return accurate results. The problem only happens when the file's hosted.

Issue appears to be file-specific, not server-wide (you'd think closing and opening the file via the Admin Console would fix the problem...but alas). I uploaded a brand new FileMaker file to the server in the video while the issue was still happening, and doing a find on an unstored calc in the brand new file worked fine.

Finds won't work in Pro nor a server-side schedule. Haven't tested web publishing.

Workaround

Restart the database server or open the file locally.

Outcomes