3 Replies Latest reply on Apr 15, 2012 8:57 PM by rmanook

    First record not importing in csv data after converting file to FM12 format from FM11

    MarkPoole

      Summary

      First record not importing in csv data after converting file to FM12 format from FM11

      Product

      FileMaker Pro

      Version

      12.0v1

      Operating system version

      Windows 7

      Description of the issue

      Running a database that ran fine in FM11 now after converting to FM12 file format, csv imports are skipping the first record as if I told it to skip first row with header info. In the script that does the import, when I look at the file that will be imported “don’t import first record” is greyed out and checked.

      After comparing scripts and import routines in version 11 and 12 I see what the problem is.

      In version 11 where you specify details about the file that will be imported, you could have selected “All Files (*.*)" and the import would include all records in the file as if you had selected “Data” in the First Row Options.

      In version 12 you have to select “Comma-Separated Text Files (*.csv; *.txt)" in the import script step and with that selected, the script will cause the First Row Options dialog to open where you can select “Data” for the choice to import the first row.

      My scripts have “All Files (*.*)” for the file types because for many previous versions of FM, I was doing manual imports that were csv format but did not have either the .csv or .txt file descriptors so I started the practice of using “All Files” so the descriptor would not filter any file types for display to the user. In previous versions of FM, while creating these import scripts the dialog allowed for the First Row Options choice even with the "All Files *.*" file type chosen.

      Up until version 12 this did not cause any issues so something changed in version 12.

      Steps to reproduce the problem

      Create a script in FM11 that includes a file import script step and choose the "All Files *.*" file type. In FM11 make the choice "Data" under First Row Options so the import will include the first record.

      Convert the FM11 file to FM12 and run the script.

      Expected result

      In version 12 the import should get all records.

      Actual result

      In version 12 it skips the first record.

      Exact text of any error message(s) that appear

      No error message

      Configuration information

      None

      Workaround

      Edit any scripts where this is an issue and select “Comma-Separated Text Files (*.csv; *.txt)" and then select the First Row Option "Data"

      FileMaker_Pro_Advanced_-_%5BCWS%5D_2012-04-13_11-30-19.png