11 Replies Latest reply on Apr 25, 2013 4:49 PM by bcheang

    FM 12.04 updater problems

    bcheang

      Summary

      FM 12.04 updater problems

      Product

      FileMaker Pro

      Version

      12.04

      Operating system version

      Mac OS X 10.8

      Description of the issue

      After applying the latest update, it seems that FM Pro now cannot remember passwords.

      Expected result

      Files should be able to open with passwords saved in the Keychain.

      Actual result

      Login dialog box pops up every time the file is opened.

      Configuration information

      Mac OS X v10.8.3
      16GB RAM

        • 1. Re: FM 12.04 updater problems
          Fred(CH)

               Hi,

               Thank you for posting bcheang !

               I can also confirm this new issue. Too bad...

               Bye, Fred

          Edit : I forgot details :
               The entry in keychain is created, even two times for the same file (weird) if you attempt many times.
               So it seems that is retrieving information that fails.
               I use Mac 10.8.3 with late 2009 iMac 27 inch 2.8 GHz Intel core i7.
               It worked properly yesterday... with FMP 12.0v3 !
                
          • 2. Re: FM 12.04 updater problems
            bcheang

                 I have a little more to add.

                 It seems like this problem is limited to local files. If the file is hosted on Filemaker Server, this issue does not surface.

            • 3. Re: FM 12.04 updater problems
              Fred(CH)

                   bcheang,

                   Sorry but i cannot confirm this exception.

                   Are you shure that the difference is not in the File Options, with Login defined on "when opening this file" section ?

                   I use FMSA 12.0v4 and FMPA 12.0v4 both on 10.8.3 Mac OS systems. And the bug always occurs.

                   Bye, Fred

              • 4. Re: FM 12.04 updater problems
                TSGal

                     bcheang and Fred:

                     Thank you for your posts.

                     I am unable to replicate the issue.  This is what I have done:

                     1. Using FileMaker Pro 12.0v3 under Mac OS X 10.8.3, I created a new database file locally, Test.fmp12, with a couple of Text fields.

                     2. Under File -> Manage -> Security, I duplicated the Admin account, clicked Edit, changed the account name to TSGal with password TSGal.

                     3. Under File -> File Options -> Open, I unchecked the box "Long in using:".

                     4. I closed the file, reopened the file, entered TSGal/TSGal, and checked the box "Remember this password in my keychain", and clicked OK.

                     5. I closed the file, reoopened the file, and I was brought directly into the file without being prompted for a password.

                     6. I quit FileMaker Pro 12.0v3, and installed the FileMaker Pro 12.0v4 updater.

                     7. I launched FileMaker Pro 12.0v4, confirmed by pulling down the FileMaker Pro menu and selecting "About FileMaker Pro".

                     8. I opened Test.fmp12, and I was NOT prompted for the password.  The file opened directly.

                     9. Files hosted with FileMaker Server 12 still opened using the Keychain.

                     Let me know what I'm doing differently than you so I can reproduce the issue.

                     TSGal
                     FileMaker, Inc.

                • 5. Re: FM 12.04 updater problems

                       bcheang and Fred:

                       Thank you for the posts.

                        

                       I would like to gather more information on this issue. Could you provide specific steps to replicate this?

                        

                       Is replication as simple as using the keychain in Mac OS X 10.8.3 and updating to FileMaker Pro 12.0v4?

                        

                       TSFalcon

                       FileMaker, Inc.

                  • 6. Re: FM 12.04 updater problems
                    TSGal

                         bcheang and Fred:

                         Our Testing department has been able to reproduce the issue on some of the Mac machines.  This issue does not occur on Windows machines.  The issue only occurs with the FileMaker Pro 12.0v4 updater; not with the full version.  We are temporarily removing the Mac updater until this matter can be further investigated and resolved.  I will keep you updated as information becomes available.

                         I know both of you are running under Mac OS X 10.8.3, so any other information you can provide about your database file(s) might be helpful.  For example, how many accounts exisst in your file(s)?  Is the keychain failing for a file with Full Access privileges?  Guest privileges?  Anything you can do to help us narrow this issue down, even if you think it might not be relevant, would be appreciated.

                         TSGal
                         FileMaker, Inc.

                    • 7. Re: FM 12.04 updater problems
                      Fred(CH)

                           Thanks to All.

                           I have some goooood news for you : this bug only appears after applying updater and until you restart your computer (or close session, we must to verify).

                           It is related to the Access control of the Keychain (see screenshot). I verified surely this point because before restarting my computer, if i allowed all applications, the bug never appear...

                           Conclusion : this issue is not very important because only a little restart solve it.

                      cheeky

                           Bye, Fred

                      • 8. Re: FM 12.04 updater problems
                        TSGal

                             Fred:

                             Thank you for the update.

                             The settings for my file were identical to yours (Confirm before allowing access) and I cannot replicate the issue.

                             bcheang - Can you confirm a restart fixes the issue?

                             TSGal
                             FileMaker, Inc.

                        • 9. Re: FM 12.04 updater problems
                          TSGal

                               Fred and bcheang:

                               Our Testers confirm that a reboot fixes the issue.

                               TSGal
                               FileMaker, Inc.

                          • 10. Re: FM 12.04 updater problems
                            philmodjunk

                                 I've added this one to the Known Bugs List so people that encounter the issue can find it, but logged it as "closed" as it just needs a restart to fix the issue.

                            • 11. Re: FM 12.04 updater problems
                              bcheang

                                   Yes, rebooting appears to have solved the problem. Thanks, guys.