9 Replies Latest reply on Apr 4, 2013 8:31 AM by disabled_mrw-old-account-do-not-use

    FM Bug: Swiss date separator is wrong

      Summary

      FM Bug: Swiss date separator is wrong

      Product

      FileMaker Pro

      Version

      FM11 and fmp12

      Operating system version

      Mac OSX 10.7.5

      Description of the issue

      On a Macintosh Computer with Swiss settings FileMaker interprets the date delimiter incorrectly, using a slash instead of a dot.

      This means:

      Any FileMaker database opened on such a mac with "Use Formats from System" will always incorrectly show a "/" in dates instead of dots.
      Any FileMaker database created/cloned on such a mac stores the incorrect "/" delimiter in the files format-settings.
      If this file is opened on a windows system and the option "Use Formats from File" is selected, the incorrect delimiter is even regurgitated on the windows system.
      Swiss mac users cannot create a FileMaker database which shows dates correctly, without having to initially create every file on a windows computer!
      In order to convert a functioning database for swiss mac users it is essential to convert the database using a windows computer with swiss regional settings.

      Windows works fine.

      Steps to reproduce the problem

      1. Get a mac
      2. In the system settings set langauge to German (Deutsch) and region to Switzerland (Schweiz)
      3. If you want to be sure that the settings are 'properly' set, then restart your computer (but not really necessary)
      4. Create an FM-DB with a date field set to auto-enter creation date.
      5. Create a layout with the date field on it.
      6. Create a record.
      7. Look and believe.

      Expected result

      Something like 28.11.2012

      Actual result

      Something like 28/11/2012

      Exact text of any error message(s) that appear

      "*!?***@!!!-S***!" - expletive from the developer ;-)

      Configuration information

      This bug was originally posted & discussed on the technet forum: https://fmdev.filemaker.com/message/101508#101508

      Workaround

      No practical workarounds.

      Windows works ok, however, so you could: Create all of your FM Files on a swiss windows system and set the option in each file to use formats from file.

      Wrong_Date_Delimiter_on_Mac_with_Swiss_Formats.png

        • 1. Re: FM Bug: Swiss date separator is wrong
          philmodjunk

               It IS a display issue. You can change the settings on the inspector's data tab to show the desired date delmitters.

               System Format settings affect how Filemaker interprets data that is entered into a date field during data entry--in particular, whether the first number entered identifies the month or the day portion of the date. You should find that during data entry, any number of delimitters such as ., / and - can be used, but the delimitter that is displayed once you exit the field will depend on what was used to enter the date if "as entered" was specified, or it will use the delimitter you specify in the Inspector's Data tab.

          • 2. Re: FM Bug: Swiss date separator is wrong

                 Hello Phil,

                 It is NOT a display issue. I DID change the settings on the inspector's data tab to show the desired date delmitters: i.e. "as entered".

                 And because I expected to hear this answer I went as far as taking a screenshot of the inspector SHOWING that this field is set to "displayed as entered". OK my screenshot is in german, but I think it is still possible to see that it is not set to a specific delimiter.
                 -----------------
                 To make it easier I am uploading a file that i created on my mac using "New Database" while my mac was set to German/Switzerland.
                  
                 Because of this FM-OSX-Swiss-Date-Delimiter-Bug the file has a "/" incorrectly stored in it for the date delimiter.
                  
                 The file is set to "Use settings from the file", and thus you should see that the date fields incorrectly contain a slash.
                  
                 To be sure that it is a data problem and not a display problem, just click in the field and it STILL contains a slash.
                  
                 And to be really convinced that the slash is at the data level just export the DateCreate field as a tab file - and you'll see it contains - incorrectly - a slash.
                  
                 To see this bug dynamically:
                   
            1.           Take ANY FileMaker file containing a date field on a layout with setting "Display as entered".
            2.      
            3.           Open it on a mac
            4.      
            5.           Set the file's setting to "Use system settings"
            6.      
            7.           Press Command Minus to enter today's date           
                               
              1.                     You should IMMEDIATELY see the date format of your current system
              2.           
                   
            8.      
            9.           Change the system language to German (Deutsch) and land to Germany (Deutschland).           
                               
              1.                     You should IMMEDIATELY see the date with dots
              2.           
                   
            10.      
            11.           Change the system land to Switzerland (Schweiz).           
                               
              1.                     You should IMMEDIATELY see the date - incorrectly - with slashes.
              2.           
                   

                 The number field works correctly.

                 In the forum discussion Martin Braendle has made a very important observation, which probably explains this "BUG":

                  

                 

            "The reason might be this old KB article http://help.filemaker.com/app/answers/detail/a_id/189/

                 

                       

                 

                      which was applicable for FM7, but who knows, maybe also for later versions?

                 

                       

                 

                      Swiss use decimal point both for date and number separator..."

                 The KB article states

                 Regional Settings For Date Fields Not Supported When The Separator Is A Period "."

                 [It then explains that if both number delimiter and date delimiter are the same, e.g. a dot ".", that input of a short date without the year (e.g. 12.2) causes an error instead of automatically inserting the year.]

                  

                 RESOLUTION:
                 Do not use a period "." as a date separator.


                 EXPLANATION:
                 In FileMaker Pro 7 this is expected behavior. The behavior has changed due to added support for Timestamp fields. Basically, the decimal separator, date separator, and time separator cannot be the same. Regional settings for date fields are not supported when the separator is a period '.' 

                  

                 So it seems that the bug of this thread is simply the lesser of two evils, because if both date and number delimiters are a dot, this causes another bug - that FileMaker interprets "12.2" incorrectly when entering a date.

                 FileMaker Inc.'s solution to this problem back in FileMaker 7 days was the easiest "quick fix" solution: to not support the Swiss and to request them to change their national stadard date delimiter from "." to "/"!
                  
            That is a solution that, given the modern direction of FileMaker Inc,  is no longer acceptable! Software should fit people, not force people to fit the software.
                  
                 Aha! Another interesting twist to the case: Apparently the resolution refered to in the KB Article was ONLY implemented on the Macintosh and never implemented on Windows, thus windows correctly supports the swiss "." date delimiter, AND still produces the input error as mentioned in the article (see next entry for a screen shot)
                  
                 Thus I would like to expand this entry to THREE issues:
                   
            1.           BUG 1 (this bug): FileMaker should support the Swiss Date Delimiter of "." ON THE MAC AND
            2.      
            3.           BUG 2 (the input bug of the KB Article) : FileMaker should improve it's data-input algorithm ON MAC AND WINDOWS on systems where the date and number delimiter are the same, so that FileMaker correctly interprets an input of "12.2"  in Swiss date fields as the twelfth of February of the current year.
            4.      
            5.           If both of these BUGs are corrected, then both Mac and Windows should demonstrate exactly the same behaviour for date fields on Swiss systems.
                 Maybe this problem was not such a big issue in the past because the number of MAC users in Switzerland was so low. As the MAC gains in popularity this problem will become increasingly relevant. It is particularly a problem for us, Günther Business Solutions GmbH, at the moment, beacause we are converting our solution predominantly for the Swiss print sector, where MACs are more prevalent.
                  
                 I thank you for your time, Phil, and would ask you to pass on this information to the FileMaker developers as soon as possible.
                  
                 Greetings from a land that fortunately uses different delimiters.
                  
                 MrWatson
                  
                 P.S. OK, so I can't upload an FM-File - I'll send it by email if requested.
                  
            • 3. Re: FM Bug: Swiss date separator is wrong

                   And here is a fourth aspect to this Bug-conglomeration.

              Bug: Unhelpful "/" error message when Date "12.2" is entered without a year (on (Swiss) systems where the date-delimiter=number-delimiter=".")

                     
              •           If I create a file for the Swiss on a windows machine (so that it has the correct "." date-delimiter stored in it) and 
              •      
              •           the user then tries to enter a date without a year (on Windows OR Mac)
              •      
              •           the error message (as displayed in the last entry) provokes the user to enter a date using a slash! - This is NOT helpful!
              •      
              •           If the user enters a date with a slash, the date is stored on the data level with a slash - and that breaks interfaces to other software, export scripts, etc.

                   The solution to this "Bug-conglomeration" should support *all* aspects of FileMakers dates for Swiss users using their own "." date-delimiter!

                   Thanks again

                   MrWatson

              • 4. Re: FM Bug: Swiss date separator is wrong

                Clarification of what I mean by "NOT a display issue":

                     When I say it is NOT a display issue, I mean, it is an issue at the data-storage-level and not caused by fixed settings in the layout.

                     What we SEE in the layout is the delimiter that is stored in the data.

                     All the dates that I have tested were not entered by hand, rather they were either

                       
                •           automatically created (via auto enter creation date)
                •      
                •           entered using the calender pop-up, or
                •      
                •           using the Command Minus menu item.

                     Thus the delimiter used was determined by the application and not by the user.

                     Thanks.

                • 5. Re: FM Bug: Swiss date separator is wrong
                  CamelCase

                       I can confirm this bug on OS X 10.8 with FileMaker 12.0v3.

                       And it's definetly just NOT a display bug but just yet another sign of the age-old fundamental "strangeness" in the way FileMaker handles regional formats, not least for dates.

                  • 6. Re: FM Bug: Swiss date separator is wrong
                    philmodjunk

                         @MrWatson,

                         I thought your screen shot showed "as entered", but what I am suggesting is that you NOT use "As entered" but rather that you specify the desired delimitter.

                         What is not clear from your original post is what delimitter was originally used to input the date. Did you use / or . ? If you used . and "as entered" is showing /, then I will agree with you that there is a bug in how the date is being displayed.

                    • 7. Re: FM Bug: Swiss date separator is wrong
                      CamelCase

                           You don't need to input a date to get a date... You get the same issue with a calculated field, e.g. You don't even need to have a file open; any calc in the data viewer that gives a date result has the same formatting error with Swiss German regional settings, whereas e.g. "German German" works fine and shows the 30.11.12 format. I really believe the issue here is related to the fact that date and decimal separator are the same, and that FileMaker then "chooses" to revert to the default date separator. Which most certainly is a bug - other software handles this fine.

                      • 8. Re: FM Bug: Swiss date separator is wrong
                        Markus Schneider

                             I'm really tired of this discussion and I'm happy about MrWatson's post. We tried several times to make that problem clear to non-Swiss users (ie FileMaker Germany), no success. IT IS A BUG! And its not new - its since FM7 imho

                             There is only one way to check it out: Get a SwissGerman System. There are some workarounds like creating the db-file on a german system (with other problems, ie comma as decimal delimiter (we got the point)) or importing into a clone (doesn't help much)

                             Phil: If You click into a date-field, delimiters become a slash. When You leave the field, delimiters go back to the setting for that field..

                             Another problem here is, that some Swiss users are aware of the US date-format... and sometimes, they enter a date in the US format because it looks like the US format (slashs) -> but then, they enter the month as day... (we got dd.mm.yyyy, becomes dd/mm/yyyy, ie 10/11/2012, when clicking into the field)

                        • 9. Re: FM Bug: Swiss date separator is wrong
                          Hello Phil, this entry has been sleeping for 1/3 year... What is the state of these bugs, please? Have they been registered by FMI as bugs? - BUG 1 (this bug): FileMaker should support the Swiss Date Delimiter of "." ON THE MAC - BUG 2 (the input bug of the KB Article) : FileMaker should improve it's data-input algorithm ON MAC AND WINDOWS on systems where the date and number delimiter are the same, so that FileMaker correctly interprets an input of "12.2"  in Swiss date fields as the twelfth of February of the current year. - BUG 3 Both Mac and Windows should demonstrate exactly the same behaviour for date fields on Swiss systems. Thanks MrWatson