1 2 Previous Next 18 Replies Latest reply on Mar 30, 2012 11:27 PM by cdragon

    FM Pro 10 Crashing When Instant Web Publishing

    marsmuse

      Summary

      FM Pro 10 Crashing When Instant Web Publishing

      Description of the issue

      I'm trying FMPro out for the first time and am frustrated that I can't get the Instant Web Publishing to work. I've imported a DB, done a layout, and can export to HTML, etc. However, whenever I "share" via IWP, FMPro crashes when I fill out the IWP dialogue window and try to click "OK."  Clicking "OK" causes the crash.  Below is a screenshot of the IWP window just before I click OK. I'm running the latest version of FMPro 10 on Mac OS X 10.5.6 Server.In Console, I see the following type of error with each crash:3/12/09 12:06:03 AM [0x0-0xc20c2].com.filemaker.client.pro bind() failed: Permission denied 3/12/09 12:06:03 AM [0x0-0xc20c2].com.filemaker.client.pro bind() failed: Permission denied 3/12/09 12:06:06 AM [0x0-0xc20c2].com.filemaker.client.pro FileMaker Pro(5672,0xa018c720) malloc: *** error for object 0x1fdaf600: non-page-aligned, non-allocated pointer being freed 3/12/09 12:06:06 AM [0x0-0xc20c2].com.filemaker.client.pro *** set a breakpoint in malloc_error_break to debug   In the recover.log, I get this:2009-03-11 23:38:57.549 -0400 software_inventory Converted.fp7 0 *** Started consistency check of improperly closed file, total of 54 block(s) to check2009-03-11 23:38:57.586 -0400 software_inventory Converted.fp7 0 Page 7 marked free but not in free list2009-03-11 23:38:57.587 -0400 software_inventory Converted.fp7 0 Page 47 marked free but not in free list2009-03-11 23:38:57.587 -0400 software_inventory Converted.fp7 0 Page 49 marked free but not in free list2009-03-11 23:38:57.587 -0400 software_inventory Converted.fp7 0 Page 50 marked free but not in free list2009-03-11 23:38:57.587 -0400 software_inventory Converted.fp7 0 Page 54 marked free but not in free list2009-03-11 23:38:57.597 -0400 software_inventory Converted.fp7 0 *** Completed consistency check, checked 54 block(s) And the crash report's last few lines before crash are:Exception Type:  EXC_BAD_ACCESS (SIGSEGV)Exception Codes: KERN_INVALID_ADDRESS at 0x00000000fffffffcCrashed Thread:  0Thread 0 Crashed:0   com.filemaker.client.pro       0x000af7f9 std::basic_ostream& std::operator

        • 1. Re: FM Pro 10 Crashing When Instant Web Publishing
          TSGal

          marsmuse:

           

          Thank you for your post.

           

          FileMaker has port 591 registered, so instead of using port 81, try port 591.  Otherwise, there may be a port conflict that would need to be tracked down.

           

          If this still fails, disconnect from the network and see if you are able to turn on Instant Web Publishing (you should be able to).  If this is a problem, create a new user account on that machine, log onto that new user account, launch FileMaker Pro , create a new file and see if you can turn on Instant Web Publishing.  If so, then reconnect to the network and try again.  I'm trying to determine if this is a network problem, OS problem, FileMaker problem, etc.

           

          Each of these answers take me down completely different paths, so let me know if any of these work, and we'll proceed from there.

           

          TSGal

          FileMaker, Inc. 

          • 2. Re: FM Pro 10 Crashing When Instant Web Publishing
              

            I have a similar problem. I am running Mac OS X and filemaker 10 decided to stop launching properly. I get a message that says "Filemaker cannot share files over the Web because of a port number conflict. Please configure web publishing to use a different port." whenever I try to open any database.

             

            I tried trashing prefs files and disconnecting from the network. Still stops running after I click OK when it asks me to change the Port address. It was set to 80, I tried 591 and 1024 and a few others.

             

            I created a new user account and launched filemaker pro from there. It launched normally.

             

            Now -- how do I repair it on my main account?

             

            Thanks for your help!

            • 3. Re: FM Pro 10 Crashing When Instant Web Publishing
              TSGal

              fyrdude:

               

              Thank you for your post.

               

              My inclination is to first run "Disk Utility".  This can be found in the following directory/folders:

               

              Hard Disk -> Applications -> Utilities -> Disk Utility

               

              Launch "Disk Utility", select the hard disk, and click the option "Repair Disk Permissions".  This will make sure everything on your hard disk is fine.

               

              Reboot your machine, and make sure no other application is loaded/running.  (I'm trying to isolate the problem and not have any possible conflicts.).  Launch FileMaker Pro, open your database file and try to turn on Instant Web Publishing.  Try the default of port 80 first.  If not, then 591.

               

              Please keep me posted with your progress.

               

              TSGal

              FileMaker, Inc. 

              • 4. Re: FM Pro 10 Crashing When Instant Web Publishing
                marsmuse
                  

                Thanks for getting back to me on this... Unfortunately, none of the tests suggested thus far have helped.

                 

                I tried:

                 

                1. Changing port to 591 in the "advanced" dialog. (Exiting from this dialog also causes a crash... as always.)
                2. Turned off all network connections, including internal wireless, and had the same crash described before.
                3. I then created a new user account, while still disconnected from the network, and experienced the same crash as on my main account. (Most of these tests were after trying to change the port to 591.)
                4. Finally, I trashed my FMPro 10 preferences in the main account and started from scratch. You guessed it... no better.

                One wrinkle in this process you should also know about. With the release of the latest seed of 10.5.7 server, I went ahead and installed that since writing last week. These tests were therefore conducted on an instance of 10.5.7 rather than 10.5.6.

                 

                Any other ideas? 

                 

                 

                • 5. Re: FM Pro 10 Crashing When Instant Web Publishing
                    

                  Thx TSGal. I'm not sure if these are both the same issue or not; let me know if I should take mine to a separate thread so as to avoid confusion, if necessary.

                   

                  I repaired permissions. There were a few repairs made. After rebooting the computer, I tried to launch FM Pro 10. The first attempt, it started to launch, and then crashed before the splash screen. The second attempt brought up the dialogue box just after the splash screen. The setting was 591. It crashed. Then I changed it on the next attempt too 80 and it crashed also.

                   

                  Next ideas?  Thank you for your help.

                  • 6. Re: FM Pro 10 Crashing When Instant Web Publishing
                    TSGal

                    marsmuse:

                     

                    Thanks for trying those steps.

                     

                    Unfortunately, I do not have access to 10.5.7, and since it isn't yet released, I would not want to put that on my machine.

                     

                    Do you have access to another machine that does not have 10.5.7?  If so, can you try it there and see if you run into the same problem?  If the problem goes away, then you will have to determine if there are any additional differences between the two machines besides 10.5.7.

                     

                     

                    fyrdude:

                     

                    No, keep it in the same thread.  It's still the same problem, and if others encounter a similar problem, it is probably easier for the users to look in one place instead of multiple places.

                     

                    Next, I would delete ALL FileMaker preference files in the user account directory that is causing problems.  Since FileMaker Pro is working in a new account, new preference files were created in that working user account directory.

                     

                    Delete the FileMaker plist file.  It is located:

                     

                    Home (user account causing problems) -> Library -> Preferences -> com.filemaker.pro.plist   (depending on which version)

                     

                    Delete the FileMaker Preferences folder in the same folder.  That is:

                     

                    Home -> Library -> Preferences -> FileMaker Preferences (folder)

                     

                    Launch FileMaker Pro.  It will not see any preference files and create new ones.  If this still doesn't work, then I would replace the preferences folder and plist file with that from the other user Preferences directory and try again.

                     

                     

                    Keep me updated with your progress (or lack thereof).

                     

                    TSGal

                    FileMaker, Inc.

                    • 7. Re: FM Pro 10 Crashing When Instant Web Publishing
                        

                      Bingo. I'm fixed. Deleting the preferences files fixed it. The first time I started troubleshooting, I deleted the FM Pro folder in the preferences folder, but I did not know abou the plist files.

                       

                      After deleting all of the above, it is launching as normal -- looks like all is well again.

                       

                      Thank you sooooo much for your help.

                       

                      :) :) :)

                      • 8. Re: FM Pro 10 Crashing When Instant Web Publishing
                        RBD2
                          

                        Hope it is OK to tag on here.  As I have the same problem.  I have had this problem for about a year and it has held true from my last machine to a new computer (2009 24" iMac) 

                          

                         

                        I have tried all the fixes in other threads, with no luck.  

                         

                        When I set up a brand new user account and logon with that (Vanilla) user, still crashes, and has no Language selection.   

                         

                        But logging onto root, works every time. 

                         

                        Any Ideas?  

                         

                         

                        • 9. Re: FM Pro 10 Crashing When Instant Web Publishing
                          marsmuse
                            

                          RBD2 wrote:
                          ... But logging onto root, works every time. 

                           


                          Bingo! Although I didn't log in as root, the web publishing function worked fine when I launched FMPro 10 as root (using  Chalaut). Hopefully this provides some clue... Clearly it's a permissions problem, but I don't want to be launching the software as root every time!
                          Hope you can figure it out...
                           Thx 

                           

                          • 10. Re: FM Pro 10 Crashing When Instant Web Publishing
                            TSGal

                            RBD2 and marsmuse:

                             

                            Since this now works from the root level, it appears that it may be a permissions issue for the user accounts.

                             

                            Open your hard disk, open the Applications folder, right-click the FileMaker folder and select "Get Info".  At the bottom of the Get Info dialog box, check the settings for "Sharing and Permissions".  Make the sure the Privilege setting is set to "Read & Write".  You might want to just set the option for "everyone" to also be "Read & Write".  This will set the changes for everything inside that folder, including the access to Instant Web Publishing.  If a user account is set to Read Only for the FileMaker folder, this would definitely cause Instant Web Publishing to not turn on.

                             

                            Please continue to keep me updated!

                             

                            TSGal

                            FileMaker, Inc. 

                            • 11. Re: FM Pro 10 Crashing When Instant Web Publishing
                              RBD2
                                

                              Set permissions for myself and for everyone to Read & Write.  Still crashes.  I feel it has to have something to do with the permissions that connected to Status Language Area.  What ever that is.  

                               

                              It comes up with a language in root and it works, and is blank in all other accounts including newley created accounts.

                               

                              Thanks for keeping at it.  I see a lot of others searching for the answer to the problem.  

                              • 12. Re: FM Pro 10 Crashing When Instant Web Publishing
                                marsmuse
                                  

                                Permissions are fine all the way up the directory tree (they were user/group read/write all along). 

                                 

                                One more variable that I want to know if you think is significant: I'm running FMPro 10 from another partition on the server (not the boot partition). FMPro didn't complain about being installed there, so I assume it makes no difference, but thought I'd ask.

                                 

                                Where is FMPro trying to write files when it does web publishing? Perhaps there's a permissions is there.

                                 

                                • 13. Re: FM Pro 10 Crashing When Instant Web Publishing
                                  RBD2
                                    

                                  The machine I am now having the problem on, (The second machine with the same problem,) is a brand new 24" iMac (a few weeks old,) no other partition, and everything vanilla other than lots of added applications. 

                                   

                                  Last night I tried to set permissions to everything I thought might be an issue to "everyone" had "Read & Write," still crashed the same way.

                                   

                                  I might now try to find a missing file in the roots home that is not in my home. ??  I will be looking for something to do with languages..

                                   

                                   

                                  • 14. Re: FM Pro 10 Crashing When Instant Web Publishing
                                    TSGal

                                    RBD2 and marsmuse:

                                     

                                    Thank you for the information.

                                     

                                    The Web publishing is handled through the "FM Web Publishing" located in the Filemaker Extensions folder (Web Publishing).  I noticed there also exists a web.prefs document in that folder, and when I removed it from the folder, re-launched FileMaker Pro, a new web.prefs file was created.  I'm trying to obtain more information about the web.prefs file, but if it is currently corrupt, my guess is it my contribute.  Try moving that file to the desktop, relaunch FileMaker Pro and try again.

                                     

                                    There was a case in FileMaker Pro 9 where someone had a similar issue, and that was traced back to Server OS, iChat and a port conflict.

                                     

                                    Are all of you new users to FileMaker Pro?  Or, were these files created in an earlier version?  

                                     

                                    Have you tried uninstalling and reinstalling FileMaker Pro?

                                     

                                    It is obvious that I don't have an answer (since I can't reproduce it), but I'd like to get as much information and see if there is any commonality to this problem.

                                     

                                    TSGal

                                    FileMaker, Inc. 

                                    1 2 Previous Next