0 Replies Latest reply on Mar 12, 2013 9:01 AM by disabled_Ed-Case

    FM Server Advanced CWP XML anomalies

      Summary

      FM Server Advanced CWP XML anomalies

      Product

      FileMaker Server

      Version

      12.0.3

      Operating system version

      Mac OS 10.6.8

      Description of the issue

      Hello,

      I posted a note regarding this to the FM Tech network and to the FM Server forum hoping it might be picked up someone at Filemaker. However, in spite of a number of viewings I have received no responses. I therefore decided to try here... I apologise for the lengthy explanation, but I find from previous experience that it tends to save any responder (I should be so lucky) either making assumptions or asking further questions. Having said that, I am happy to expand further...

      I created my CWP templates in my previous versions of FMSA: 8 and then 9 (never tried 10 or 11). They worked fine until I upgraded to FMSA 12, where the following anomalies were encountered.

      The results for the following examples are taken from the FMSA 12 Admin Console log viewer

      Date field search:

      US Date format:
      192.168.1.127 192.168.1.128:50001 - XML 500 500 "/fmi/xml/FMPXMLRESULT.xml?-db=MyDatabase&-lay=Main&-sortfield.1=SessionID&-sortorder.1=descend&-lop=and&session status.op=bw&session status=open&session date.op=bw&session date=03/08/2013&-max=50&-skip=0&-find"

      Result = 0 (should be 5)

      UK Date format:
      192.168.1.127 192.168.1.128:50003 - XML 500 500 "/fmi/xml/FMPXMLRESULT.xml?-db=MyDatabase&-lay=Main&-sortfield.1=SessionID&-sortorder.1=descend&-lop=and&session status.op=bw&session status=open&session date.op=bw&session date=08/03/2013&-max=50&-skip=0&-find"

      Result = 0 (correct as UK date formats do not work with any version of FMSA I have used)


      Number field search:

      "/fmi/xml/FMPXMLRESULT.xml?-db=MyDatabase&-lay=Main&-lop=and&Record_no.op=bw&rec_no=1924&-max=50&-skip=0&-find"

      Result = 10 (1924, 19240, 19241, 19242, 19243, 19244, 19246, 19247, 19248, 19249) - there is no 19245 record. Should be a single record returned.

      Both the Date and Number search issues are resolved by adding an 'eq' operator

      Next... and this example is a change of functionality that I find very difficult to resolve:

      Text search omitting records using op=neq

      "/fmi/xml/FMPXMLRESULT.xml?-db=MyDatabase&-lay=Main&-lop=and&Web_Search.op=bw&Web_Search=Isfahan&RestrictCountry.op=neq&RestrictCountry=UK&-max=50&-skip=0&-find"

      Result = 6 (RestrictCountry ignored - result should be 0 with restriction to UK)

      Restrict Country field for all these records looks like this: "UK, USA, Fra"

      - - - -

      Each of the above queries returned correct results in FMSA 9. Most vexing is that the neq functionality (appears) to have chnaged from excluding a result where the field CONTAINED the term or terms, to excluding only where the field exactly matched the term or terms.

      Is this behaviour in FMSA 12 known to Filemaker, a purposeful change or an error. Are Filemaker planning on changing this behaviour (at least the neq, please) soon in an update? These kinds of changes between versions - especially after a change as big as from 11 to 12, requiring as it did a host of file conversions - are extremely frustrating to business users such as myself, whose business relies on smooth transitioning from one version to another.

      Thank you for reading,

      Colin S

      Steps to reproduce the problem

      See details in Description of the issue

      Expected result

      See details in Description of the issue

      Actual result

      See details in Description of the issue

      Exact text of any error message(s) that appear

      See details in Description of the issue

      Configuration information

      none

      Workaround

      Yes.
      Date and Number fields work when an 'eq' is added before the relevant field

      NEQ... By encapsulating the list of countries into a repeating field (one repetition for each country) I can search using neq and it will omit any record containing that country if it has an entry in the repeating field.
      Whilst this is okay in this instance, I am concerned about the lost functionality of 'neq' and would much prefer not to have to create some humungous repeating field