2 Replies Latest reply on Apr 5, 2012 1:48 AM by gcatnine

    FM SERVER Installation - Java installatio

    gcatnine

      Summary

      FM SERVER Installation - Java installatio

      Product

      FileMaker Server

      Version

      v11

      Operating system version

      wondows 7, windows vista, server

      Description of the issue

      at installation time, FM server do not check if there Java is installed with a more recent version and install an older version.
      i.e now we are at version 31 and it still installed version 26.
      so, after the installation you need to remove all Java installation and re-install the latest version.
      BTW, FMS works very well with Java v 31.

      Steps to reproduce the problem

      Install FMS

      Expected result

      FMS installation process check if there Java is installed with a more recent version

      Actual result

      FMS reinstall the old version

      Exact text of any error message(s) that appear

      NA

      Configuration information

      NA

      Workaround

      Install FMS, remove Java, reinstall JAVA

        • 1. Re: FM SERVER Installation - Java installatio
          iDEViate

          From what I've seen FMS11v3 is bundled with Java 6 u24. If you completely remove java it will prompt to install u24 upon the installation of FMS. 

           

          Keep in mind that Java updates come out much quicker than FileMaker Server updates. The installer your running for FMS may have been compiled over a year ago and will include an outdated version of Java.  

           

          The java version bundled with the installer is a known good working and tested version. 

           

          Thanks

          • 2. Re: FM SERVER Installation - Java installatio
            gcatnine

            Sorry, but that's not the problem.

            the FM installation do not continue if you do not accept the Java installation, so you are forced to install the old version of Java

            so the process should be either:

            or check the Java version already installed (if there is one) and if it is higher, do not install Java

            or prompt the user if he wants to install Java, explicating with version is going to install