4 Replies Latest reply on Oct 22, 2014 9:46 AM by TSGal

    FM13 won't import Bento data

    konnektor

      Summary

      FM13 won't import Bento data

      Product

      FileMaker Pro

      Version

      13

      Operating system version

      10.10

      Description of the issue

      i can't import bento data into a new or existing FMP13 database.

      Steps to reproduce the problem

      when i ask FMP13 to convert an existing file, and select bento data source

      Expected result

      FMP13 converts the bento datafile into an FMP database

      Actual result

      i get a popup message

      Exact text of any error message(s) that appear

      You must have Bento 2 (or a later supported version) installed on this computer.

      Configuration information

      mac os 10.10
      bento 4.1.2 - was running fine before yosemite upgrade

      Workaround

      none

      Screen_Shot_2014-10-19_at_09.32.03.jpg

        • 1. Re: FM13 won't import Bento data
          RichardHangHong

          I'm having the same problem! Please let me know if you get an answer to this.

          I'm running the FM Pro 13 trial version and have downloaded the migration tool so I can move my Bento 4 database across to FM Pro but every time I open the migration tool I get this message.

          "Database requires upgrade. Only Bento 4.1.1 and Bento 4.1.2 databases are supported"

          Clicked "Okay" and it says "No Database found" so I then choose File > Open and select my database at which point it crashes.

          In FM Pro I have tried Converting an Existing File, I select "Bento Data Source" and it crashes immediately. 

          Can someone tell me what I'm doing wrong please or give me some advice on what I need to do?

          Thanks

           

          • 2. Re: FM13 won't import Bento data
            TSGal

            konnector and Richard Hang Hong:

            Thank you for your posts.

            First, make sure you do not have an older version of Bento on your machine.  The reason being is that when you select "Bento Data Source...", FileMaker asks the operating system to launch Bento application, and it will launch the first instance of Bento it can find.

            I've tried a few things here, and I discovered that if I have Address Book integration turned on in Bento 4.1.2, then I do get the same error as konnector.  That is, "You must have Bento 2 or later...".

            The only time I get "No Database found" is when there is no database in the default directory:

            <User Account> -> Library -> Application Support -> Bento -> bento.bentodb

            At no time do I receive a crash.  With that said, what version of Bento are you using?  And, where is the bento.bentodb file located?

            TSGal
            FileMaker, Inc.

            • 3. Re: FM13 won't import Bento data
              konnektor

              4.1.2 only installed, in correct default directory.

              any other files possibly contributing to the failure of both bento launch and FP import?

               

               

              • 4. Re: FM13 won't import Bento data
                TSGal

                konnektor:

                The more I play with this, the more I discover.

                With Address Book integration turned off, I do get the ability to import a Bento Library (as mentioned earlier), but I just discovered that no matter which Library I select to import, no records are imported.  Even if I select importing into a new table, the fields are created, but no records are imported.

                TSGal
                FileMaker, Inc.