AnsweredAssumed Answered

FMGO Client fails to commit data back to FM PRO Host

Question asked by philmodjunk on Jul 23, 2014
Latest reply on Jul 28, 2014 by philmodjunk

Summary

FMGO Client fails to commit data back to FM PRO Host

Product

FileMaker Go

Version

FMPRO ADV 13.0v3, FM GO 13.0.4

Operating system version

iOS 7.1.2 / Windows 7

Description of the issue

Created a simple, brand new FMP 13 database and hosted it from a windows 7 machine using FileMaker Pro Advanced as the server.

When I created new records on the iOS client. New records did not show on the FM PRO host.

Tried a number of steps to get the data to commit so that the host would update and nothing worked. I switched layouts, created a second new record and nothing changed on the host.

When I closed the file on the host and re-opened the file, the newly created records had disappeared.

In the uploaded screen shot, what I saw on the host is shown on the right and what I saw on the iOS client is shown on the left.

Exact text of any error message(s) that appear

The fact that there was NO error message that data would be lost if I closed out the client was especially troublesome.

Configuration information

I am not sure if this is part of the issue or a separate issue, but files hosted on this W7 machine keep becoming inaccessible until I restart FileMaker on that machine and then reconnect the iOS client via WiFi.

When I closed the client, I also had to restart and reconnect before I could access the database file and discover that the newly added data was not saved to the database.

This appears to be yet another FM GO "ephemeral bug". I could create new records on the client but could not delete them and the records could not be saved back to the host.

Then, after several times of closing and opening the file on both devices, new records suddenly started being saved back to the server and I could delete the new records.

CommitRecordsBug.png

Outcomes