5 Replies Latest reply on Jan 21, 2012 9:44 AM by DavidWillcox

    FMP 11v4 incompatible with PGP Desktop 9.8

    DavidWillcox

      Summary

      FMP 11v4 incompatible with PGP Desktop 9.8

      Product

      FileMaker Pro

      Version

      11v4

      Operating system version

      OS 10.6.8

      Description of the issue

      Just started using FMP 11. I converted an old FMP 6 database to 11. Really a very simple database, basically just a bunch of records with documents embedded.

      After converting, I tried to make a change to one of the layout parts. FMP reliably quits when I try it.

      I've tried doing a "Recover," and it just says that nothing was changed.

      I tried re-converting from the original FMP 6 document.  Same thing happens.

      For what it's worth, the layout has a rather long text field that extends over multiple pages. (I just want to print everything that's in a large text field, as long as it needs to be.

      Steps to reproduce the problem

      From any layout, enter layout mode mode.

      Try either "Layout setup" or "Part setup."

      Expected result

      I expect an application to do basic operations without crashing.

      Actual result

      It crashes.

      I'm not impressed.

      Exact text of any error message(s) that appear

      FileMaker Pro quit unexpectedly.

      Configuration information

      For what it's worth:

      Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
      0   com.filemaker.client.pro           0x0002a2d6 CMacCmdTarget::FindCmdMsg(unsigned int, int) + 134
      1   com.filemaker.client.pro           0x00030236 CocoaCommandHandled + 38
      2   com.filemaker.client.pro           0x004d2ec1 -[CocoaDialog actionForCommandID:] + 33
      3   com.filemaker.client.pro           0x0054c1e6 findResponderAndSelectorForCommand + 150
      4   com.filemaker.client.pro           0x0054c526 -[NSApplication(FMXApplicationAdditions) targetAndAction:forCommand:] + 134
      5   com.filemaker.client.pro           0x005607b6 CocoaResponderChain::TryToPerformCommand(unsigned int) + 70
      6   com.filemaker.client.pro           0x001964d8 AppHandleCommand(FMDocWindow*, unsigned int, bool) + 664
      7   com.filemaker.client.pro           0x0015b79f CFMProApp::OnCommandRange(unsigned int) + 111
      8   com.filemaker.client.pro           0x0002a489 CMacCmdTarget::OnCmdMsg(unsigned int, int, void*, MAC_CMDHANDLERINFO*) + 313
      9   com.filemaker.client.pro           0x000376c0 CMacFrameWnd::OnCmdMsg(unsigned int, int, void*, MAC_CMDHANDLERINFO*) + 96
      10  com.filemaker.client.pro           0x005107ad CMacDesktopFrameWnd::OnCmdMsg(unsigned int, int, void*, MAC_CMDHANDLERINFO*) + 45
      11  com.filemaker.client.pro           0x00054764 XMenu::DischargeContextCommand() + 100
      12  com.filemaker.client.pro           0x00216465 FMDocWindow::MouseDown(XNEventRecord, Draco::LayoutPart::PartType) + 229
      13  com.filemaker.client.pro           0x002166d0 FMDocWindow::MouseDownHandler(XNEventRecord const&, Draco::LayoutPart::PartType, bool) + 144
      14  com.filemaker.client.pro           0x004eb837 -[FMContentViewCocoa mouseDown:] + 375
      15  com.apple.AppKit                   0x93633b28 -[NSWindow sendEvent:] + 5757
      16  com.filemaker.client.pro           0x0046e4dc -[FMDocWindowCocoa sendEvent:] + 140
      17  com.apple.AppKit                   0x9354c60b -[NSApplication sendEvent:] + 6431
      18  com.apple.AppKit                   0x934e0253 -[NSApplication run] + 917
      19  com.filemaker.client.pro           0x00028602 CMacApp_Main + 418
      20  com.filemaker.client.pro           0x0015d643 main + 51
      21  com.filemaker.client.pro           0x00003826 start + 54

        • 1. Re: FMP 11v4 incompatible with PGP Desktop 9.8
          philmodjunk

          Even though it said nothing was changed, did you test the recovered copy anyway to see if you get the same crash? (Recover also resets a number of things in your file to original values and rebuilds all your file's indexes so sometimes the recovered file will work ok even though it reported no problems found.)

          You can also try recovering the file in FileMaker 6 and then converting this recovered copy to see what you get.

          The next step after that, if you still get crashes would be to remove this one problem layout and rebuild it from scratch in your database. THere could be some bit of layout corruption causing trouble that recover is not successfully repairing.

          • 2. Re: FMP 11v4 incompatible with PGP Desktop 9.8
            DavidWillcox

            Yes, I did try the FMP11 version after the recovery. Same probllem.

            Background: This is a database of meeting minutes, so each record has several small fields (date, committee, attendees...) and one field with up to 4 pages of text with formatting (bold, italics, etc.).

            No, I didn't think to recover the FMP6 version before conversion.  But actually, it gets worse.

            I tried exporting the FMP6 version as XML, then importing into FMP11.  I lost all my layouts, and formatting of the data in the one big field, but at least I figured I'd have my data.

            But even in the initial, default layout, if I try to do Layout Setup, FMP crashes.

            In fact, if I say "New Database", then immediately go to layout mode (without creating any fields or records or importing anything), sometimes FMP crashes immediately, sometimes it waits for me to say "Layout Setup."

            Now I'm even less impressed. Such a basic operation of this shouldn't cause the app to crash.

            I suppose maybe I should go back to 11v1 and see if this is something introduced in a later release.

            • 3. Re: FMP 11v4 incompatible with PGP Desktop 9.8
              philmodjunk

              So a newly created database also causes this crash?

              If so you may need to look at your computer for issues.

              Make sure it's healthy by running a disk utility to check for trouble.

              Trash the preferences file for Filemaker.

              Re-install Filemaker.

               

              If this were typical for Filemaker files on a Mac, this forum would be inundated with reports of the same. Since it's not, I'm betting on an issue specific to your computer.

              • 4. Re: FMP 11v4 incompatible with PGP Desktop 9.8
                DavidWillcox

                Well, so OK, I concede that it's something related to my computer.

                Install on a different (almost identical) MBP: I can't reproduce the problem.

                Fresh OS install on an external disk on my MBP: I can't reproduce the problem.

                But, reinstall the OS and FMP11 on my main disk (not a "clean from scratch" install, though), and I see the fault. With just about any database, even a new one created from one of the templates, if I try to do "part setup" for one of the parts, boom, SIGSEGV.

                I tried removing preferences, but I can't find anything that looks like FMP11 preferences. The only one I can find is for FMP6.

                Could having both FMP11 and FMP6 installed break something? It shouldn't but you never know.

                Suggestions, anyone?

                Thread 0 Crashed: Dispatch queue: com.apple.main-thread
                0 com.filemaker.client.pro 0x0002ddb6 CMacCmdTarget::FindCmdMsg(unsigned int, int) + 134
                1 com.filemaker.client.pro 0x00033d16 CocoaCommandHandled + 38
                2 com.filemaker.client.pro 0x004d7141 -[CocoaDialog actionForCommandID:] + 33
                3 com.filemaker.client.pro 0x005506a6 findResponderAndSelectorForCommand + 150
                4 com.filemaker.client.pro 0x005509e6 -[NSApplication(FMXApplicationAdditions) targetAndAction:forCommand:] + 134
                5 com.filemaker.client.pro 0x00564c76 CocoaResponderChain::TryToPerformCommand(unsigned int) + 70
                6 com.filemaker.client.pro 0x00199a78 AppHandleCommand(FMDocWindow*, unsigned int, bool) + 840
                7 com.filemaker.client.pro 0x0015ef4f CFMProApp::OnCommandRange(unsigned int) + 111
                8 com.filemaker.client.pro 0x0002df69 CMacCmdTarget::OnCmdMsg(unsigned int, int, void*, MAC_CMDHANDLERINFO*) + 313
                9 com.filemaker.client.pro 0x0003b1a0 CMacFrameWnd::OnCmdMsg(unsigned int, int, void*, MAC_CMDHANDLERINFO*) + 96
                10 com.filemaker.client.pro 0x005147ad CMacDesktopFrameWnd::OnCmdMsg(unsigned int, int, void*, MAC_CMDHANDLERINFO*) + 45
                11 com.filemaker.client.pro 0x00058294 XMenu::DischargeContextCommand() + 100
                12 com.filemaker.client.pro 0x00219885 FMDocWindow::MouseDown(XNEventRecord, Draco::LayoutPart::PartType) + 229
                13 com.filemaker.client.pro 0x00219af0 FMDocWindow::MouseDownHandler(XNEventRecord const&, Draco::LayoutPart::PartType, bool) + 144
                14 com.filemaker.client.pro 0x004ef987 -[FMContentViewCocoa mouseDown:] + 375
                15 com.apple.AppKit 0x92bd5b28 -[NSWindow sendEvent:] + 5757
                16 com.filemaker.client.pro 0x0047286f -[FMDocWindowCocoa sendEvent:] + 143
                17 com.apple.AppKit 0x92aee60b -[NSApplication sendEvent:] + 6431
                18 com.apple.AppKit 0x92a82253 -[NSApplication run] + 917
                19 com.filemaker.client.pro 0x0002c10d CMacApp_Main + 413
                20 com.filemaker.client.pro 0x00160dd3 main + 51
                21 com.filemaker.client.pro 0x00003586 start + 54

                 

                • 5. Re: FMP 11v4 incompatible with PGP Desktop 9.8
                  DavidWillcox

                  I seem to have found the answer. This was by pure luck.  If anyone has any comments about how to systematically track down this kind of problem, I'd like to hear it.

                  (Anyone remember "Conflict Catcher" from the Classic Mac days? Great program.)

                  It appears to be PGP Desktop 9.8. It has known issues with recent versions of MacOS, but as far as I had heard, that was only for disk encryption. I use it only for email.

                  This is the first time I've run into a problem. If I remove the PGP*.framework files from /Library/Frameworks, FMP11 appears to be fine. With the files moved back, FMP11 crashes.

                  It sounds like I have to live without either FMP11 or PGP Desktop. (Or find out if there's an upgrade path for the latter.)  Rock and hard place.

                  Any suggestions on how to make the two coexist?