1 2 Previous Next 28 Replies Latest reply on Mar 30, 2009 10:10 AM by DH#1

    FMP 9 wont start after install.

    mxfreeman

      Summary

      FMP 9 wont start after install.

      Description of the issue

      Im on a Macbook Pro, OSX 10.5.6. This machine had FMP 8.5 Adv and it was removed. Now I want to install FMP 9 on it. The install goes without error, Ive upgraded to v.03 without error. But It wont start. I get the message: "Some of the files that are needed have either been damaged or have not been installed. Please run the installer to correct these problems". I find nothing in the installer that offers to fix these problems. I have removed and installed multiple times. used appdelete to make sure there are no associated files still lingering..and still nothing. Any help would be appreciated. myk

        • 1. Re: FMP 9 wont start after install.
          TSGal

          mxfreeman:

           

          Thank you for your post.

           

          Here is what I have done on my iMac running OS X 10.5.5.

           

          1. I downloaded a trial version of FileMaker Pro 9.

          2. After installation, I launched FileMaker Pro and it started without a problem.

          3. I quit FileMaker Pro 

          4. I downloaded the updater to v3.

          5. I installed the v3 updater.

          6. I launched FileMaker Pro and it started without a problem.

           

          Please follow the steps above and let me know if it fails at step #6, or if it fails earlier at step #2.

           

          TSGal

          FileMaker, Inc.

          • 2. Re: FMP 9 wont start after install.
            wallcur
              

            Hi,

             

            My system is giving me the exact same error message.  I followed your instructions and nothing changed.  I have a full version of FMP 7 and we purchased the upgrade to FMP 9.  Our computer recently got a new HD put in and they reinstalled everything on our backup drive back onto the computer.  Since then I have not been able to open FMP.  I have tried deleting all version of FMP from the computer and starting from scratch with an installation and it still won't work.  I have also downloaded the V.3 updater as well.

             

            Our computer is a Mac running Tiger.  Any help would be greatly appreciated, thank you! 

            • 3. Re: FMP 9 wont start after install.
              rmanook

              Hi mxfreeman and wallcur,

              Let's try the following:

              1.  Uninstall FMP 9

              2.  Remove the Mac HD/Library/Preferences/FLEXnet Publisher/FLEXnet:filemaker_######_tsf.data file

              3.  Repair Disk Permissions

              4.  Reboot

              5.  Re-install FMP 9

               

              Let me know how it works out.

              Thanks!

              tsturtle

              FileMaker, Inc. 

               

              • 4. Re: FMP 9 wont start after install.
                wallcur
                  

                Hi ts_turtle,

                 

                thank you for your speedy reply.  i followed your instructions exactly and unfortunately it did not work.  the same error message appeared.

                 

                do you have any other suggestions?

                 

                thanks again! 

                • 5. Re: FMP 9 wont start after install.
                  rmanook

                  Hey wallcur,

                   

                  Just to verify, are you using a CD or an ESD (Electronic Software Download from FileMaker webstore)?  If this is a CD, is this the original media?  Also, are you performing a network install or are you installing locally at the machine?

                   

                  Let's try un-installing FMP using the steps in my previous reply.  Next, we'll create a new user account and try installing under the new user account for testing purposes.

                   

                  Also, if possible, do you have any success installing the FMP 10 installer?  This would help rule out the installer as the issue.

                   

                  Thanks wallcur,

                  tsturtle

                  FileMaker, Inc. 

                  • 6. Re: FMP 9 wont start after install.
                    wallcur
                      

                    Hello again,

                     

                    I have a CD of both FMP 7 and 9.  7 installed no problem and opened no problem. 9 is where the problem is.  I also tried both attempts using first the CD to install 9 and then even the trial version that I downloaded from the FMP support site.  Neither worked )c:

                    I am installing them locally on the machine.

                     

                    I'm assuming you mean create a new user account on the Mac OS?

                     

                    I haven't downloaded the FMP10 installer.  Will it still be possible to use 9 if I download 10?  I've consulted my employer about upgrading but since they just bought 9 about 6 months ago they want to wait a while longer until we upgrade to 10.

                     

                    Thanks again! 

                    • 7. Re: FMP 9 wont start after install.
                      mattwatts
                        

                      There was an issue with an apple update that caused problems. I phoned filemaker support and they suggested the following: 

                       

                      1. Delete the FileMaker Pro 9 folder and empty the trash.
                      2. System Preferences > Date & Time, modify the system date back to 1st Sept. 2008

                      3. Perform a new installation of Filemaker Pro 9
                      4. Once installation is done, go back to System Preferences > Date & Time, and modify the system date back to the current date.

                       

                      It sounded odd to me too, but it worked!

                      • 8. Re: FMP 9 wont start after install.
                        wallcur
                          

                        Hi MWatts,

                         

                        Thank you so much for your reply, I tried everything you said and unfortunately this did not work either.  I'm still getting the same error message )c:

                         

                        Thanks again though for your help! 

                        • 9. Re: FMP 9 wont start after install.
                          ccity
                            

                          I'm having the exact same problem. I've tried both the FMP9 CD and the FMP9 Trial CD that came with it.

                           

                          Just in case it matters, I have a PowerPC running 10.4.11. I'm also pretty certain that it ran successfully at one time several months ago when I first installed it, but it doesn't anymore (I haven't tried using it since).

                          • 10. Re: FMP 9 wont start after install.
                            rmanook

                            wallcur wrote:
                              

                            Hello again,

                             

                            I have a CD of both FMP 7 and 9.  7 installed no problem and opened no problem. 9 is where the problem is.  I also tried both attempts using first the CD to install 9 and then even the trial version that I downloaded from the FMP support site.  Neither worked )c:

                            I am installing them locally on the machine.

                             

                            I'm assuming you mean create a new user account on the Mac OS?

                             

                            I haven't downloaded the FMP10 installer.  Will it still be possible to use 9 if I download 10?  I've consulted my employer about upgrading but since they just bought 9 about 6 months ago they want to wait a while longer until we upgrade to 10.

                             

                            Thanks again! 


                            Hey wallcur,
                             Thanks for responding.
                            You're correct; I would suggest trying a new user account (make sure this is an admin acccount) in the Mac OS, log into the new account, and then install FMP 9.  Also, is there another machine to install FMP 9 to narrow down the issue to the machine/installer?
                            You can definitely use FMP 9 even if you installed the FMP 10 trial.  I would suggest downloading the trial just for testing purposes.
                             
                            Thanks for hanging in there,
                            tsturtle
                            FileMaker, Inc. 

                             

                            • 11. Re: FMP 9 wont start after install.
                              rmanook

                              Hi ccity,

                              Thanks for posting.

                              Just to verify, have you tried the steps previously noted in the thread?  If not, please verify the following:

                              1.  Uninstall FMP 9

                              2.  Remove the Mac HD/Library/Preferences/FLEXnet Publisher/FLEXnet:filemaker_######_tsf.data file

                              3.  Repair Disk Permissions

                              4.  Reboot

                              5.  Re-install FMP 9 

                               

                              Here is the resolution given from Tech Support (phone) to MWatts:

                              1. Delete the FileMaker Pro 9 folder and empty the trash.
                              2. System Preferences > Date & Time, modify the system date back to 1st Sept. 2008

                              3. Perform a new installation of Filemaker Pro 9

                              4. Once installation is done, go back to System Preferences > Date & Time, and modify the system date back to the current date.

                               

                              Let me know how it works out

                              Thanks,

                              tsturtle

                              FileMaker, Inc. 

                              • 12. Re: FMP 9 wont start after install.
                                DH#1
                                  

                                Howdy Folks.

                                Seems this problem is contagious or something.

                                 

                                I've been using FMP9 Adv on this system for more than 2 years, through a variety of OS upgrades.  

                                Just yesterday, FMP9 Adv stopped starting properly and instead displayed:

                                 

                                Some of the files that are needed are either damaged or have not been installed.  Please run the installer to correct this problem.

                                 

                                All right.  Did that.  Same complaint.  Googled.  Found this thread.  Followed the 2 recommendations listed above:

                                1) Uninstall FMP9 Adv

                                2) Delete /Lib/Pref/FLEX...

                                3) Repair Disk Perms

                                4) Reboot.

                                5) Back Date to 9/1/08

                                6) Install FMP9 Adv

                                7) Reset Date to present

                                8) Start app.  NO JOY.

                                I've tried the installers on the CD, the disk image and the v3 image.  Same complaint each time.

                                 

                                Seems FMP9 may no longer be cooperative with OS 10.5.5 or 10.5.6.   

                                Reinstalling to a down rev OS is not a good answer. 

                                 

                                Where do I look to find the files which are causing the problem?

                                What else to do?

                                 

                                Thanks in advance for your valued suggestions. 


                                • 13. Re: FMP 9 wont start after install.
                                  DH#1
                                    

                                  Just installed FMP 10 Trial.

                                  And guess what?

                                  It works!

                                   

                                  So.  I have to conclude that FMP 9 Adv doesn't like 10.5.5 or 10.5.6

                                   

                                  • 14. Re: FMP 9 wont start after install.
                                    DH#1
                                      

                                    After our power failed last evening, I had nothing better to do than beat my head silly trying to figure this out.

                                     

                                    I installed FMP 8 Adv.  It works fine.

                                    Reinstalled FMP 9 Adv.  No Joy.

                                    Archive & Reinstalled OS 10.5.1.  Check Disk Perms - no surprise, but all files were fine.  Installed FMP 9 Adv.  No Joy.

                                    Even tried backdating the system to 9/1/08 and reinstall FMP 9 Adv, then reset date.  No Joy.

                                    Tried FMP 9 Adv v3.  No Joy. 

                                     

                                    Oddly, there was never any files installed in /Library/Preferences/FLEXnet Publisher/FLEXnet 

                                     

                                    So, let me modify my previous post and suggest, that recent experiences suggest that installing FMP 9 Adv ( an app from a subsidiary of Apple) from scratch on a Mac Pro (an Apple product) running a newly installed 10.5.1 OS (also an Apple product) is a sure recipe for frustration.

                                     

                                    1 2 Previous Next